Oscillating idle and High idle (random) - DIYPNP - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-11-2013, 10:39 AM   #1
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default Oscillating idle and High idle (random) - DIYPNP

Hey,

I got my car running and tuned (mostly), two things left bugging me...

1. Oscillating idle, sometimes the idle is rock-solid and sometimes it is oscillating 200rpm up and down.

2. Rarely, the idle is stuck as high as 3000rpm...

I would very much like to fix the drop when starting the ac (or any time the compressor is switched on)

it is a 97 NA Turbo miata with DIYPNP running idle closed loop.

I will post my idle cl config as soon as i get home.

Thank you guys.
elior77 is offline   Reply With Quote
Old 04-11-2013, 10:46 AM   #2
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,175
Total Cats: 2,578
Default

iacv going out?
18psi is offline   Reply With Quote
Old 04-11-2013, 10:47 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

get running on gslender firmware. input the a/c switch and output the a/c compressor.

tune tune tune.
Braineack is offline   Reply With Quote
Old 04-11-2013, 12:22 PM   #4
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

Quote:
Originally Posted by 18psi View Post
iacv going out?
If you ask if the iac is operational - yes.
elior77 is offline   Reply With Quote
Old 04-11-2013, 12:29 PM   #5
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

My cl setup:







Attached Thumbnails
Oscillating idle and High idle (random) - DIYPNP-64548164.png   Oscillating idle and High idle (random) - DIYPNP-92934916.png   Oscillating idle and High idle (random) - DIYPNP-67681812.png   Oscillating idle and High idle (random) - DIYPNP-60185107.png  
elior77 is offline   Reply With Quote
Old 04-11-2013, 12:43 PM   #6
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,175
Total Cats: 2,578
Default

post a screenshot of your fuel and timing map
18psi is offline   Reply With Quote
Old 04-11-2013, 12:44 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

that's a lot of I value.

you are also telling the ECU that at 64% PWM, you should be seeing around 1300RPM, I would expect you to be closer to 3000RPM at that PWM%.
Braineack is offline   Reply With Quote
Old 04-11-2013, 12:57 PM   #8
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default





I will try lower I, what should I try ?

About the 1300rpm, I will check and put in the right value for 64%pwm.
Attached Thumbnails
Oscillating idle and High idle (random) - DIYPNP-14887847.png   Oscillating idle and High idle (random) - DIYPNP-79846803.png  
elior77 is offline   Reply With Quote
Old 04-11-2013, 01:02 PM   #9
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,175
Total Cats: 2,578
Default

both your tables definitely need smoothing out at idle too
that's way too much variation between cells that are supposed to be really close together and smooth to maintain a good idle....IMO
18psi is offline   Reply With Quote
Old 04-11-2013, 01:08 PM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

what you shoudl really do it use idle valve test mod eand find out the min/max duty and RPM as measured on your own car.
Braineack is offline   Reply With Quote
Old 04-12-2013, 01:14 AM   #11
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

Thanks guyz !


Last edited by elior77; 04-12-2013 at 01:14 PM.
elior77 is offline   Reply With Quote
Old 11-05-2014, 04:15 PM   #12
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

The truth is that CL didn't work then, it took me one more year to get it right.

https://www.miataturbo.net/megasquir...-reason-81672/

*Just closing up all my threads with the solutions I found.
elior77 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:41 AM.