Question about CMP and CKP signal mods... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-07-2009, 11:31 AM   #1
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Posts: 219
Total Cats: 0
Default Question about CMP and CKP signal mods...

Braineak built my MS and I've got it running but am planning to move to the Hi-Res firmware and put in my 550cc injectors in prep for adding the turbo afterwards. I wanted to make sure these mods were done to my MS so I busted it open and I've been searching around and see from this page: How to MegaSquirt your Mazda Miata

the section: -How to mod a MegaSquirt-I PCB2.2 ECU-

It looks like the CMP mod was done, but I'm not so sure about this part:
"CKP Signal" -- We just need a 12v pullup. Install a 470ohm 1/4w resistor between the right side (non-band) end of D5 and the right hole (banded) end of D9.

Looking at my board nothing is wired into the diode in D5 but I just wanted to make sure it wasn't done some other way I'm not aware of. Also, I found this thread: https://www.miataturbo.net/forum/t25383/ at the bottom Joe says:
"Make sure that you have no jumpers installed on the MS PCA in either TSel or TachSelect."

Looking at my board there is a jumper between TachSelect and "Optoin". Should I remove this? And can you tell by looking at my board if I still need to do the CMP Signal mod-sorry about the pic, best I could do, my camera is old. Thanks!
Attached Thumbnails
Question about CMP and CKP signal mods...-ms-pic-1.jpg  
scottv is offline   Reply With Quote
Old 02-07-2009, 01:47 PM   #2
Senior Member
iTrader: (3)
 
Join Date: Feb 2006
Location: Centennial, CO
Posts: 672
Total Cats: 20
Default

If you have the car running on Megasquirt, then the mods have obviously been done, otherwise the car wouldn't run. Also, you are looking at the 2.2 board instructions, you have 3.0

Running HiRes is as easy as just flashing the firmware, no other mods needed.
karter74 is offline   Reply With Quote
Old 02-07-2009, 01:57 PM   #3
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,327
Total Cats: 1,926
Default

Quote:
Originally Posted by scottv View Post
It looks like the CMP mod was done, but I'm not so sure about this part:
"CKP Signal" -- We just need a 12v pullup. Install a 470ohm 1/4w resistor between the right side (non-band) end of D5 and the right hole (banded) end of D9.
It looks to me like you have the pullup on D1, it was just taken from somewhere other than D9.


Quote:
Also, I found this thread: https://www.miataturbo.net/forum/t25383/ at the bottom Joe says:
"Make sure that you have no jumpers installed on the MS PCA in either TSel or TachSelect."
That was specific to a user who was building Abe's crank input circuit, which bypasses the whole on-board hall/opto circuit. In the standard config, you jumper TachSelect to OptoIn, OptoOut to Tsel, and XG1 to XG2.
Joe Perez is offline   Reply With Quote
Old 02-07-2009, 02:04 PM   #4
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Posts: 219
Total Cats: 0
Default

Thanks guys!
scottv is offline   Reply With Quote
Old 02-07-2009, 02:57 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

Quote:
Braineak built my MS and I've got it running but am planning to move to the Hi-Res firmware and put in my 550cc injectors in prep for adding the turbo afterwards.
didn't I already load the hi-res firmware?

Quote:
It looks to me like you have the pullup on D1, it was just taken from somewhere other than D9.
acutally...look again, it's going to the banded end of D9...




what are the two wires you have attached to what looks to be the boot jumper?
Braineack is offline   Reply With Quote
Old 02-07-2009, 05:40 PM   #6
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Posts: 219
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
what are the two wires you have attached to what looks to be the boot jumper?
I wired a momentary switch into the case so that I could press a button to perform the boot jumper function without having to take the case apart. works good. I don't know if Hi-Res was originally loaded-I loaded the PNP firmware and went from there. Thanks
scottv is offline   Reply With Quote
Old 02-07-2009, 08:45 PM   #7
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,327
Total Cats: 1,926
Default

Quote:
Originally Posted by Braineack View Post
acutally...look again, it's going to the banded end of D9...
Ah, yes it is. Nice how all the wires are different colors so that it's easy to tell them apart.
Joe Perez is offline   Reply With Quote
Old 02-07-2009, 09:17 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

it worse when since i've started using black wire.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
NA Seat Sliders and Seat Belt Receivers skipstr Miata parts for sale/trade 2 09-28-2015 11:53 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:34 AM.