RPM's hang returning to idle. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-17-2009, 12:16 AM   #1
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default RPM's hang returning to idle.

I have started experiencing the weirdest issue i have ever seen and I have no idea what it is.

If I rev the engine, even blip the throttle past 1200 rpm just slightly, on the way back down the rpm's would hang at 1200 for 3 seconds and then drop to normal idle.

If I am in gear, slowing down, force the rpm's down below 1200 rpm and get off the clutch, they will bounce back up to 1200 for 3 seconds and then come down to normal idle.

At first I thought it was my throttle cable getting caught, but thats not it. I thought maybe the IAC but it responds properly to the AC turning on and the fans.


I am completely baffled. It started happening just out of the blue.
Saml01 is offline   Reply With Quote
Old 03-17-2009, 12:40 AM   #2
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

You could try adjusting your dashpot. It will have a similar effect if adjusted out too much. Although it wouldn't really explain why your idle would just back up to 1200rpm. Something to check out, mine had a similar issue (Link) until I backed off the dashpot.
jayc72 is offline   Reply With Quote
Old 03-17-2009, 10:40 AM   #3
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

I should have probably mentioned that I dont use MS for idle.
Saml01 is offline   Reply With Quote
Old 03-17-2009, 11:06 AM   #4
Junior Member
 
Join Date: Aug 2005
Location: So Cal
Posts: 125
Total Cats: 0
Default

Quote:
Originally Posted by Saml01 View Post
I should have probably mentioned that I dont use MS for idle.
I have the same thing and I like it. I find that it helps me in stop and go traffic. it helps with the engine not to bog down. I thought I had a stuck cable too but it seems to be normal behavior.
RdSnake is offline   Reply With Quote
Old 03-17-2009, 11:10 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,787
Default

does it happen if the idle valve is disconnected?
Braineack is online now   Reply With Quote
Old 03-17-2009, 02:01 PM   #6
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by Braineack View Post
does it happen if the idle valve is disconnected?
I haven tried this because for me to disconnect the idle valve is a mission and a half. But I assume because the RPM's hang and then drop, its the IAC doing it.

Unless you want to tell me that if I disconnect it and the symptom stops then my IAC is acting up.

Quote:
Originally Posted by RdSnake View Post
I have the same thing and I like it. I find that it helps me in stop and go traffic. it helps with the engine not to bog down. I thought I had a stuck cable too but it seems to be normal behavior.

I will agree that this is an inadvertent benefit which is why it doesnt bother me that much. Still strange though.
Saml01 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:15 PM.