TPS spikes and misfires over 4k rpm and boost - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-12-2013, 03:37 PM   #1
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 15
Total Cats: 0
Default TPS spikes and misfires over 4k rpm and boost

Hi there,

I installed Reverant's enchanced MS2 a week ago and I have trouble running boost over 4k rpm.

I noticed I have spiky TPS reading, but I have no idea how to deal with it. The car stumbles randomly over 4k RPM - the tach acts crazy too. This happens almost every time after WOT.

I'm attaching log screen so you can see for yourself.
Attached Thumbnails
TPS spikes and misfires over 4k rpm and boost-screen-shot-2013-05-12-20.35.13.png  
conrader is offline   Reply With Quote
Old 05-12-2013, 09:16 PM   #2
Junior Member
iTrader: (-2)
 
Join Date: Nov 2012
Posts: 242
Total Cats: -42
Default

Post MSQ and log file.
Gt2560rMiata is offline   Reply With Quote
Old 05-12-2013, 09:23 PM   #3
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

It looks like you are going WAY to rich in boost. It might just be dumping too much fuel and causing a stumble.

It also looks like it is showing some kind of decel based on the TPSacc. Is your TPS variable and calibrated correctly? At the same time the TPSacc shows a drastic drop, your dutycycle falls.
miatauser884 is offline   Reply With Quote
Old 05-13-2013, 05:08 AM   #4
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 15
Total Cats: 0
Default

I'm uploading msq and 2 logs. I guess there is some noise on the TPS - maybe because most of the grounds are hooked up to throttle body.
conrader is offline   Reply With Quote
Old 05-13-2013, 05:58 AM   #5
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 15
Total Cats: 0
Default

Unfortunately I can't upload any logs because even ziped are over 1 mb. Here is the MSQ.
Attached Files
File Type: msq CurrentTune.msq (101.5 KB, 81 views)
conrader is offline   Reply With Quote
Old 05-13-2013, 06:16 AM   #6
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Can you send the datalog to my email?
Reverant is offline   Reply With Quote
Old 05-13-2013, 06:39 AM   #7
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 15
Total Cats: 0
Default

I just sent you the datalogs.
conrader is offline   Reply With Quote
Old 05-13-2013, 06:47 AM   #8
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

I can only see one sync loss, which is while idling (I presume from performing a burn).

At the exact moment you posted, you were going full rich (less than 11.0, as low as 10.3), and your coils can't handle that rich of a mixture, resulting in misfires.

Your tacho is bouncing because its driven by your coils on your 94 - multiple misfires will result in the needle bouncing around.
Reverant is offline   Reply With Quote
Old 05-13-2013, 08:42 AM   #9
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 15
Total Cats: 0
Default

So if I go leaner on boost say 11.5 - 12.0 it should help?

I'm running COPs btw.
conrader is offline   Reply With Quote
Old 05-13-2013, 09:38 AM   #10
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Aim for 11.5-11.6 in boost.
Reverant is offline   Reply With Quote
Old 05-13-2013, 09:39 AM   #11
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Btw even LSx coils will misfire at ~10.2.
Reverant is offline   Reply With Quote
Old 05-13-2013, 09:57 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

your TPS signal is very noisey still and triggering AE events.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM
VE analyze and Autotune seems funny (noob) TorqueZombie MEGAsquirt 64 09-18-2015 06:03 PM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM
ME221 Now has Autotune and Long Term Fuel Trim Tables Motorsport-Electronics ECUs and Tuning 0 09-05-2015 09:02 AM


Tags
enchanced ms2, grounds, spiky tps

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:46 AM.