TPS Wires - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-23-2007, 03:42 PM   #1
mkturbo.com
Thread Starter
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default TPS Wires

Well I redid all my wiring and I am stuck at the last 2 wires. According to the megamanual 22 is the TPS signal and 26 is the 5vref from the tps. I am in a 94 and I do not know which of the 4 wires coming from the TPS is which.

http://www.madracki.com/miata/images/wiring/94sys.pdf

That is the link for the wiring diagram for the 94. Page 8 and 9 have the wiring for the stock harness. Can any one please figure out which wires coming from thew TPS I am supposed to use.
shuiend is offline   Reply With Quote
Old 04-23-2007, 03:58 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

if i read correctly:

RED / BLK - Wiper (TPS)
BLK / BLU - Ground
RED - Switch Idle
LTGRN / WHT - 5vref
Braineack is offline   Reply With Quote
Old 04-23-2007, 04:13 PM   #3
Junior Member
 
Join Date: Jun 2006
Location: LV, NV
Posts: 225
Total Cats: 0
Default

I think Scott is right, but you can double check that with a multimeter on the blk/blu and ltgrn/wht wires. You should see voltage changing when you open the throttle.
mschlang is offline   Reply With Quote
Old 04-23-2007, 04:42 PM   #4
Junior Member
 
Join Date: Feb 2006
Location: Greenville, NC
Posts: 211
Total Cats: 0
Default

Quote:
Originally Posted by shuiend View Post
26 is the 5vref from the tps.
If its pin 26 from the Megasquirt its not 5vref from the tps, its 5v REFERNCE FOR the tps.
ecugrad is offline   Reply With Quote
Old 04-23-2007, 04:51 PM   #5
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

Quote:
Originally Posted by ecugrad View Post
If its pin 26 from the Megasquirt its not 5vref from the tps, its 5v REFERNCE FOR the tps.
I didn't use the V/ref at all, I just 'tapped' the signal line. works perfect.

when I cut the signal and 5vref line I got ECU resets every time I let off the throttle.
richyvrlimited is offline   Reply With Quote
Old 04-23-2007, 05:01 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

maybe the wot switch ***** stuff up?
Braineack is offline   Reply With Quote
Old 04-23-2007, 05:23 PM   #7
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

I also just tapped my lines for the TPS.
cjernigan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:08 AM.