Why am I so lean when the engine is cold - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-02-2011, 05:52 AM   #1
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 25
Total Cats: 0
Default Why am I so lean when the engine is cold

Chaps,

Log and MSQ attached.

Every morning, whenever i pull away when the engine is cold I go MEGAlean.

see 82794 in the log.

MSQ seems to be doing everything it should- adding more fuel etc..

I've got my warmup settings very high as a result to try to 'compensate'. you can see it's adding 160% more fuel and still hitting AFR of 19.4 under load!

Thoughts?
Attached Files
File Type: msl 2011-03-02_08.22.31.msl (243.0 KB, 52 views)
File Type: msq start test v13.msq (38.2 KB, 62 views)
Paulusuk is offline   Reply With Quote
Old 03-02-2011, 09:25 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,877
Total Cats: 1,790
Default

then obviously 160% isn't enough. Tune the ASEs and Warmup enrichments so you see 13.1 at idle below 160*F.
Braineack is online now   Reply With Quote
Old 03-02-2011, 10:02 AM   #3
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 25
Total Cats: 0
Default

Cheers- I know it's obvious and logical what I should do.

But, I know of noone else going that high - seems a bit mental... we're talking potentially 80% extra fuel! Causes problems when theres such a huge drop when the car hits 71 deg c (the WUE upper limit in tunerstudio) as i can't taper the warmup any further.

I'll increase it . I don't want to wash the bores too much, as cruise it's often dropping to 12:1.

It's only lean under cold accel. cold accel is already at 170% and tbh doesn't seem to kick in. Map dot threshold is as low as it can go (30kpa/s) without causing a hunting idle.
Paulusuk is offline   Reply With Quote
Old 03-02-2011, 10:29 AM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Time to add a TPS?
Reverant is offline   Reply With Quote
Old 03-02-2011, 10:55 AM   #5
Newb
Thread Starter
 
Join Date: Apr 2010
Posts: 25
Total Cats: 0
Default

... and to stop moaning on forums..

I think you're right.

Presumably, the vTPS would detect subtle rates of change on my right foot.

Wheras map delta wouldn't reach the right granularity because the map source can fluctuate in most conditions and becomes too sensitive.

Cheers guys..
Paulusuk is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:25 AM.