Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Bad turbo sounds

 
Old 06-26-2009, 07:55 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2008
Location: Columbia, SC
Posts: 178
Total Cats: 0
Default Bad turbo sounds

Well......I got up this morning and decided to take the Miata to the gas station instead of the bike. My car cranked fine and drove about three miles and started making this grinding/high pitched sound. It lost all power and would barely pull its own weight. The turbo wouldnt spool past 1 PSI!! It almost sounded like the wheel was hitting the housing. I turned it off and let it cool down a bit and cranked her back up. About 1/10 of a mile it started all over again. I have not moved the car in about a month but it drove fine when I parked it. Im pretty sure the turbos toast but why would it be fine last time I drove it and fucked the next time??

georgefury1 is offline  
Old 06-26-2009, 08:18 AM
  #2  
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,605
Total Cats: 135
Default

Sounds like something went through the turbo. Loose screw, chipmunk, etc
olderguy is online now  
Old 06-26-2009, 07:29 PM
  #3  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,399
Total Cats: 2,296
Default

omfg. did you put a REAL cat on your exhaust?!


pull the damn intake and look....
Braineack is offline  
Old 06-26-2009, 07:59 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Aug 2008
Location: Columbia, SC
Posts: 178
Total Cats: 0
Default

I just got home and took the intake off. No blade damage or shaft play, or signs of anything. Then I pulled my #4 plug wire and there was water poring out of it. Why did that make my turbo scream like that? Strange but fixed. I fail at mornings. lol
Here is a cute cat pic to make up for my ignorance.
funny-picturs-cat-in-exhaust.jpg
georgefury1 is offline  
Old 06-26-2009, 08:27 PM
  #5  
Senior Member
iTrader: (2)
 
Join Date: Aug 2005
Location: Granbury, TX
Posts: 562
Total Cats: 1
Default

Originally Posted by georgefury1 View Post
I just got home and took the intake off. No blade damage or shaft play, or signs of anything. Then I pulled my #4 plug wire and there was water poring out of it. Why did that make my turbo scream like that? Strange but fixed. I fail at mornings. lol
Here is a cute cat pic to make up for my ignorance.
Attachment 12407
Poor cat must have gotten all dirty up in there..
greenday3437 is offline  
Old 06-26-2009, 08:31 PM
  #6  
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,712
Total Cats: 3
Default

Originally Posted by georgefury1 View Post
I just got home and took the intake off. No blade damage or shaft play, or signs of anything. Then I pulled my #4 plug wire and there was water poring out of it. Why did that make my turbo scream like that? Strange but fixed. I fail at mornings. lol
Here is a cute cat pic to make up for my ignorance.
Attachment 12407
Aww, if that muffler is anything but new thats going to be a dirty *****!
wayne_curr is offline  
Old 06-27-2009, 03:36 AM
  #7  
Supporting Vendor
iTrader: (3)
 
Join Date: Jul 2006
Location: San Diego
Posts: 3,085
Total Cats: 902
Default

Originally Posted by georgefury1 View Post
why would it be fine last time I drove it and fucked the next time??
The nature of something breaking... first it works, then it doesn't. Sounds in order to me. When you really have a weird problem is when your car politely notifies you via love note that a failure is pending... **** breaking out of the blue is quite normal.
__________________
Ryan Passey
ThePass is offline  
Old 06-27-2009, 04:17 AM
  #8  
VladiTuned
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 35,141
Total Cats: 3,145
Default

Originally Posted by georgefury1 View Post
I just got home and took the intake off. No blade damage or shaft play, or signs of anything. Then I pulled my #4 plug wire and there was water poring out of it. Why did that make my turbo scream like that? Strange but fixed. I fail at mornings. lol
Here is a cute cat pic to make up for my ignorance.
Attachment 12407
nice ***** bro
18psi is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
StratoBlue1109
Miata parts for sale/trade
21
09-30-2018 01:09 PM
Rick02R
WTB
3
01-03-2016 07:18 PM
shooterschmidty
Engine Performance
8
09-30-2015 10:28 PM
JesseTheNoob
DIY Turbo Discussion
15
09-30-2015 02:44 PM
Greasyman
General Miata Chat
2
09-28-2015 10:44 AM


Thread Tools
Search this Thread
Quick Reply: Bad turbo sounds


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.