car wont run after begi-s install - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 07-09-2008, 02:09 AM   #1
Newb
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Posts: 41
Total Cats: 0
Default car wont run after begi-s install

So the car starts up then cuts out after 2 secs. Code 1 = IGF signal, kinda weird for something to all of a sudden stop working, where should I begin? coil packs?, CAS?, I know some people mention the MAF, but I can't see how the MAF affects the IGF signal.

car is a 1994
TurboTalon is offline   Reply With Quote
Old 07-09-2008, 02:56 AM   #2
Junior Member
 
Join Date: May 2007
Location: San Diego
Posts: 383
Total Cats: 0
Default

Quote:
Originally Posted by TurboTalon View Post
So the car starts up then cuts out after 2 secs. Code 1 = IGF signal, kinda weird for something to all of a sudden stop working, where should I begin? coil packs?, CAS?, I know some people mention the MAF, but I can't see how the MAF affects the IGF signal.

car is a 1994
Did you get the optional MSPNP? Did you remove your MAF?
jobambo is offline   Reply With Quote
Old 07-09-2008, 03:19 AM   #3
Senior Member
iTrader: (2)
 
Join Date: Nov 2007
Location: orlando, FL
Posts: 558
Total Cats: 0
Default

i doubt it's a maf...did you try giving it gas after starting the car? when i disconnected my maf, it just simply ran like ***, i mean it would shut off unless i gave it gas
XxGoKoUxX is offline   Reply With Quote
Old 07-09-2008, 04:46 AM   #4
Elite Member
iTrader: (15)
 
Join Date: Sep 2007
Location: Incline Village, NV
Posts: 2,073
Total Cats: 5
Default

We need to know more info about your car, do you have a MS? Are you still on the stock ecu? If your still on the stock ecu it sounds like a maf issue, when i had my afm on my 90 if i forgot clip it back into place it would do what sounds like the same problem you have. Start hesitate, then die. Check engine light would come on as well.
thesnowboarder is offline   Reply With Quote
Old 07-09-2008, 07:58 AM   #5
Elite Member
iTrader: (8)
 
Join Date: Sep 2006
Location: Severn, MD
Posts: 1,927
Total Cats: 5
Default

You didn't happen to do a fuel rail at the same time did you? And swap the source and return lines by accident?

Frank
fmowry is offline   Reply With Quote
Old 07-09-2008, 09:48 AM   #6
Senior Member
iTrader: (14)
 
brgracer's Avatar
 
Join Date: Nov 2004
Location: Ambler, PA
Posts: 1,275
Total Cats: 1
Default

Quote:
Originally Posted by fmowry View Post
You didn't happen to do a fuel rail at the same time did you? And swap the source and return lines by accident?

Frank
+1 or maybe reversed the fuel lines with the AFPR install?
brgracer is offline   Reply With Quote
Old 07-09-2008, 10:26 AM   #7
Newb
Thread Starter
iTrader: (2)
 
Join Date: Jan 2008
Posts: 41
Total Cats: 0
Default

I have only installed the turbo, no megasquirt, haven't even started the afpr yet, I just wanted to fire it up and check for leaks, the MAF is definetely plugged in.
TurboTalon is offline   Reply With Quote
Old 07-09-2008, 11:14 AM   #8
Elite Member
iTrader: (8)
 
Join Date: Sep 2006
Location: Severn, MD
Posts: 1,927
Total Cats: 5
Default

Bad/removed ground on the back of the head to the firewall shelf? Not sure if you removed or loosened this when you did the turbo.

Frank
fmowry is offline   Reply With Quote
Old 07-09-2008, 11:18 AM   #9
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Perhaps your Talon transmitted something to the miata? Been known to happen; communicable diseases for cars are hard to cure.
Ben is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
[CT] 1999 Mazda Miata 10th Anniversary Edition - $5800 Jike Spingleton Cars for sale/trade 3 09-20-2016 05:33 PM
Rotrex cooling issue gsyk59 Engine Performance 49 11-22-2015 05:11 AM
Ms2e 99-00 ac control Dobzeh MEGAsquirt 23 09-15-2015 05:49 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:23 AM.