HKS kit,car wont run. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 11-22-2008, 09:16 AM   #1
Ajb
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 103
Total Cats: 0
Default HKS kit,car wont run.

Well i installed my ghetto as fck HKS kit which has been modified with 1.8 injectors and also a fuel pressure regulator also not sure if the insides of the fcon mini have been played with as car was on a dyno at one point.

The car really wont start for **** , when it does it sounds like its running on 3 cylinders or maybe two and needs throttle to keep it alive and then it normally dies. I pulled the plugs and all where rich and black and two looked wet.

Could it be flooding it to **** but i dont think this explains why it sounds like its running on 3 cylinders.

Also with the fuel pressure regulator when i had it hooked in one way around it was pissing fuel out of the top of it i switched it round and since then it no longer leaks but it also has never shown any sign on the gauge of what fuel rail pressure its running.

MS is easier even with the build i feel.
Ajb is offline   Reply With Quote
Old 11-22-2008, 09:45 AM   #2
Senior Member
iTrader: (8)
 
Join Date: Oct 2005
Posts: 764
Total Cats: 0
Default

It seems to me that a combination of FCon mini, 1.8 injectors, and AFPR would indeed cause it to run extremely rich and like ****. For a 1.6 the FCon provides all the needed fuel for standard boost (6 psi) for that kit. Adding larger injectors and an AFPR would likely **** things up. The Fcon is not designed to be programmable or adjustable so if someone dicked with that then you have other issues too. My HKS 1.6 kit performed flawless for 5 yrs. Have fun with it.
miatanutz is offline   Reply With Quote
Old 11-22-2008, 10:37 AM   #3
Ajb
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 103
Total Cats: 0
Default

Well i also have a sound either EXTREME detonation or fucked HLAS or maybe a bent rod beating the **** out of the block. Sound goes away at only 2000rpm , car backfires and shoots flames.
Il upload video in bit.
Ajb is offline   Reply With Quote
Old 11-22-2008, 11:19 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

you has too much fuel.
Braineack is offline   Reply With Quote
Old 11-22-2008, 01:39 PM   #5
Ajb
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 103
Total Cats: 0
Default

Anyway the extreme knoocking sound is still present , took off the afpr and now idles. Still sounds like constant missfire een when revved up , engine sounds like large knocking from the top still also.

All four plugs black o and my WBo2 now is saying im idling at an air fuel ratio of 17-18 which is interesting.

Also managed to strip plug thread so now thats stuck in the head so i guess that has to come off and maybe engine is fucked so i should just build it and use MS instead of shitty HKS crap.
Ajb is offline   Reply With Quote
Old 11-22-2008, 01:47 PM   #6
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Sounds like you're good at ******* **** up. Yeah, do some research on engine management and wrenching. You may have hydrolocked the engine with fuel somehow and bent a rod. Compression test and leakdown test will tell you if the engine's mechanically ok.
patsmx5 is offline   Reply With Quote
Old 11-22-2008, 02:02 PM   #7
Ajb
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 103
Total Cats: 0
Default

Yea im guessing i bent a rod when i primed the motor i pulled the CAS i read somewhere it stopped the injectors but apparently not.

Obviously i knew it could strip easily as its aluminium but i only pinched it up 1/4 turn obviously too much for the day.

Also cant do complete compression test as plug is stuck in the head lol
Ajb is offline   Reply With Quote
Old 11-22-2008, 02:27 PM   #8
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by Ajb View Post
Yea im guessing i bent a rod when i primed the motor i pulled the CAS i read somewhere it stopped the injectors but apparently not.

Obviously i knew it could strip easily as its aluminium but i only pinched it up 1/4 turn obviously too much for the day.

Also cant do complete compression test as plug is stuck in the head lol
Hahahahaha. Yeah, I didn't think about that.

You got a few options.

Cheapest would be to find a used engine at a local pick and pull and swap them out. The key to getting a good price on a used engine is to find one at a U pull it type place. Cause you'll pay 500 for almost any engine no matter the condition if they have to pull it. But around here, 165 buys any engine if you pull it. Of course, you don't get a "guaranteed to run" engine. But, if you are savvy, you can find the gem in the pile of rocks. You just have to know what to look for. I've bought "long blocks" for 88 w/ tax twice with me pulling it. For me, that wasn't a problem as it allowed me to find the best engine.

Or buy a "good" engine already pulled for 300-700 as that's what they go for already pulled and supposedly good.

Or if you're ballin, rebuild your engine. But the average rebuild is 2K, and that's putting stock parts back in it. Expect to spend 2500-3000 building a forged engine by the time you start till you have an engine that's ready to run.
patsmx5 is offline   Reply With Quote
Old 11-22-2008, 03:52 PM   #9
Ajb
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: United Kingdom
Posts: 103
Total Cats: 0
Default

Il pull the head and take a look first.
If rod not bent then just head gasket and MS. If damaged, new daily sell HKS, break out the welder and FE3 time.
Ajb is offline   Reply With Quote
Old 11-22-2008, 04:07 PM   #10
Senior Member
iTrader: (8)
 
Join Date: Mar 2006
Location: Indianapolis, IN
Posts: 758
Total Cats: 5
Default

Too much fuel in a cylinder can indeed cause bad things. I installed non-nitrile rubber fuel injector o-rings on my 300zx, and this was the ultimate result:

boileralum is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fab9Tuning's NC MX-5 Turbo Kit Discussion- EFR/Garrett V-Band FAB Prefabbed Turbo Kits 216 03-22-2017 05:00 PM
NEW-Wiseco Piston, K1 Rods, Supertech Valves & Spring/Retainer, TB&C pedals Rudes333 Miata parts for sale/trade 17 11-05-2015 02:16 PM
Project DDoS: '99 "Budget" boost build ProjectDDoS Build Threads 1 09-09-2015 02:52 PM
Help installing DDM HID kit thumpetto007 General Miata Chat 8 09-04-2015 06:25 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:34 AM.