need help with issues - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 02-03-2009, 01:48 PM   #1
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default need help with issues

90 miata
125k on clock

Stock motor

Greddy manifold
Greddy turbo,
tt downpipe
No intercooler at the moment
Hks vta bov
Test pipe
stock cat back
5psi of boost

Issue number 1

Car runs fine under 4k, blows off fine, idles fine
At 4 k, it feels like the car hits a brick wall, gas pedal to the floor and it just feels like there is no power. I have new fuel injectors on the way and I bought a fuel filter but its too cold to install at the moment. Should I buy a fuel pump also??? What could be causing this symptom, also, this just happened today, the car stalled randomly, and had much trouble starting back up (mind u its 12 degrees out side)


Issue number 2

I has little heat... its 12 degrees out side, cars temp gauge says everything is normal under the hood, car is at optimal temp, but I have very little warm air out of the vents, even full blast, the air is just barely luke warm, my old miata blew lava out of the vents, so I know this is broken. I assume the lines going into the heater core might be cloged or somthing,
How do I clean them/unclog them, is there maybe a thermostat on the back of the head I don't know about, I don't look back there too often.

Those r the only issues my car has, any help any one can offer would be appriciated, thanx
urgaynknowit is offline   Reply With Quote
Old 02-03-2009, 01:53 PM   #2
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

what are you running for fuel management?
mazda/nissan is offline   Reply With Quote
Old 02-03-2009, 05:35 PM   #3
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

Quote:
Originally Posted by mazda/nissan View Post
what are you running for fuel management?
hopes n dreams

nah, lol, the fmu that the greddy kit comes with
urgaynknowit is offline   Reply With Quote
Old 02-03-2009, 05:38 PM   #4
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

on a side note, i dont know how it got up there that fast, but my post count is into the 1000;s now lol,, its up to 3 posts per day, wtf?? i didnt know i spent my life on here
urgaynknowit is offline   Reply With Quote
Old 02-04-2009, 10:58 AM   #5
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

bump
urgaynknowit is offline   Reply With Quote
Old 02-04-2009, 11:15 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by urgaynknowit View Post
on a side note, i dont know how it got up there that fast, but my post count is into the 1000;s now lol,, its up to 3 posts per day, wtf?? i didnt know i spent my life on here

i dont think you have anything to worry about in that department....
Braineack is offline   Reply With Quote
Old 02-04-2009, 11:17 AM   #7
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

omg, scott, ur **** says 17 thousand......


fix my car someone, ill post pics of the gf if the problems are fixed
urgaynknowit is offline   Reply With Quote
Old 02-04-2009, 11:18 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

for issue one, id say check your fuel pressures.
Braineack is offline   Reply With Quote
Old 02-04-2009, 12:12 PM   #9
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,669
Total Cats: 1,561
Default

Post pics of gf and we'll decide if you are worth saving. j/k

Have you had the engine open (head off, water pump) or changed the radiator? Maybe you've got silicone, rubber, or gasket material blockage.

Some systems have a valve that shuts off hot water flow as you move the mixer lever from cool to warm. I haven't yet had to check if there is one on Miatas. They are often cable or vacuum operated, so that is a point of failure.

If not, then there is still a mixer door that could be stuck or the cable is off or out of adjustment. Have you installed a new stereo or gauges near the A/C controls and possibly disturbed the cable on the back of them? Or have you done anything under the dash that might have dislocated the cable at the other end at the mixer door lever?

Does water freely flow at operating temperature (thermostat open) when you look down in the radiator filler neck? I have seen water pump impellers that corroded/wore away over time and significantly reduced flow. Just throwing it out there as a last thing to check if all else fails.

There is no factory thermostat in the back of the head. Only the front one.
sixshooter is offline   Reply With Quote
Old 02-04-2009, 12:32 PM   #10
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,124
Total Cats: 0
Default

havnt taken the motor apart, other than adding the greddy kit

i have installed a new radio, its a big indash tv, with a crap load of wires behind it, ill check this to see if this might make it work

then its off to take the rad apart and see whats going on
urgaynknowit is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:03 PM.