Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

need help with issues

 
Old 02-03-2009, 12:48 PM
  #1  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,116
Total Cats: 0
Default need help with issues

90 miata
125k on clock

Stock motor

Greddy manifold
Greddy turbo,
tt downpipe
No intercooler at the moment
Hks vta bov
Test pipe
stock cat back
5psi of boost

Issue number 1

Car runs fine under 4k, blows off fine, idles fine
At 4 k, it feels like the car hits a brick wall, gas pedal to the floor and it just feels like there is no power. I have new fuel injectors on the way and I bought a fuel filter but its too cold to install at the moment. Should I buy a fuel pump also??? What could be causing this symptom, also, this just happened today, the car stalled randomly, and had much trouble starting back up (mind u its 12 degrees out side)


Issue number 2

I has little heat... its 12 degrees out side, cars temp gauge says everything is normal under the hood, car is at optimal temp, but I have very little warm air out of the vents, even full blast, the air is just barely luke warm, my old miata blew lava out of the vents, so I know this is broken. I assume the lines going into the heater core might be cloged or somthing,
How do I clean them/unclog them, is there maybe a thermostat on the back of the head I don't know about, I don't look back there too often.

Those r the only issues my car has, any help any one can offer would be appriciated, thanx
urgaynknowit is offline  
Old 02-03-2009, 12:53 PM
  #2  
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,076
Total Cats: 0
Default

what are you running for fuel management?
mazda/nissan is offline  
Old 02-03-2009, 04:35 PM
  #3  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,116
Total Cats: 0
Default

Originally Posted by mazda/nissan View Post
what are you running for fuel management?
hopes n dreams

nah, lol, the fmu that the greddy kit comes with
urgaynknowit is offline  
Old 02-03-2009, 04:38 PM
  #4  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,116
Total Cats: 0
Default

on a side note, i dont know how it got up there that fast, but my post count is into the 1000;s now lol,, its up to 3 posts per day, wtf?? i didnt know i spent my life on here
urgaynknowit is offline  
Old 02-04-2009, 09:58 AM
  #5  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,116
Total Cats: 0
Default

bump
urgaynknowit is offline  
Old 02-04-2009, 10:15 AM
  #6  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,620
Total Cats: 2,317
Default

Originally Posted by urgaynknowit View Post
on a side note, i dont know how it got up there that fast, but my post count is into the 1000;s now lol,, its up to 3 posts per day, wtf?? i didnt know i spent my life on here

i dont think you have anything to worry about in that department....
Braineack is offline  
Old 02-04-2009, 10:17 AM
  #7  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,116
Total Cats: 0
Default

omg, scott, ur **** says 17 thousand......


fix my car someone, ill post pics of the gf if the problems are fixed
urgaynknowit is offline  
Old 02-04-2009, 10:18 AM
  #8  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,620
Total Cats: 2,317
Default

for issue one, id say check your fuel pressures.
Braineack is offline  
Old 02-04-2009, 11:12 AM
  #9  
Moderator
iTrader: (12)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 19,304
Total Cats: 2,434
Default

Post pics of gf and we'll decide if you are worth saving. j/k

Have you had the engine open (head off, water pump) or changed the radiator? Maybe you've got silicone, rubber, or gasket material blockage.

Some systems have a valve that shuts off hot water flow as you move the mixer lever from cool to warm. I haven't yet had to check if there is one on Miatas. They are often cable or vacuum operated, so that is a point of failure.

If not, then there is still a mixer door that could be stuck or the cable is off or out of adjustment. Have you installed a new stereo or gauges near the A/C controls and possibly disturbed the cable on the back of them? Or have you done anything under the dash that might have dislocated the cable at the other end at the mixer door lever?

Does water freely flow at operating temperature (thermostat open) when you look down in the radiator filler neck? I have seen water pump impellers that corroded/wore away over time and significantly reduced flow. Just throwing it out there as a last thing to check if all else fails.

There is no factory thermostat in the back of the head. Only the front one.
sixshooter is offline  
Old 02-04-2009, 11:32 AM
  #10  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Dec 2007
Location: worcester ma
Posts: 1,116
Total Cats: 0
Default

havnt taken the motor apart, other than adding the greddy kit

i have installed a new radio, its a big indash tv, with a crap load of wires behind it, ill check this to see if this might make it work

then its off to take the rad apart and see whats going on
urgaynknowit is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigmackloud
Miata parts for sale/trade
16
03-03-2019 03:41 PM
nick470
MEGAsquirt
1
09-30-2015 10:32 PM
shooterschmidty
Engine Performance
8
09-30-2015 10:28 PM
interestedofold
Suspension, Brakes, Drivetrain
5
09-29-2015 01:42 PM


Thread Tools
Search this Thread
Quick Reply: need help with issues


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.