Race Prep Miata race-only chat.
Sponsored by:
Sponsored by:

SM Weekend of Failure (wheel hubs)

 
Old 10-07-2016, 12:36 AM
  #41  
Junior Member
iTrader: (9)
 
Join Date: Dec 2011
Location: SFBay
Posts: 348
Total Cats: 40
Default

My friend had a Timken hub failure at [email protected] this past weekend.
Fortunately he managed to bring the car off track in a controlled manner.





Carnage:



He thinks there were only ~5 hours of track time on the hubs, which had ARP studs installed.

Last edited by scenturion; 10-07-2016 at 06:43 PM.
scenturion is offline  
Old 10-07-2016, 12:46 AM
  #42  
Elite Member
iTrader: (1)
 
turbofan's Avatar
 
Join Date: Sep 2010
Location: Laguna Hills, CA
Posts: 7,220
Total Cats: 628
Default

I was right behind him when that happened. We funny to watch but quite scary.
turbofan is offline  
Old 10-07-2016, 10:01 AM
  #43  
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,188
Total Cats: 656
Default

No pics. ??
hornetball is offline  
Old 10-07-2016, 10:27 AM
  #44  
Elite Member
iTrader: (1)
 
turbofan's Avatar
 
Join Date: Sep 2010
Location: Laguna Hills, CA
Posts: 7,220
Total Cats: 628
Default

Pics from me? I don't have video from that session unfortunately.
turbofan is offline  
Old 10-07-2016, 10:34 AM
  #45  
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 18,495
Total Cats: 1,636
Default

Ed. Answer your Facebook messages.
aidandj is offline  
Old 10-07-2016, 12:21 PM
  #46  
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,188
Total Cats: 656
Default

Originally Posted by turbofan View Post
Pics from me? I don't have video from that session unfortunately.
No, from scenturion. It looks like he was trying to show a picture in his post.
hornetball is offline  
Old 10-07-2016, 12:22 PM
  #47  
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 18,495
Total Cats: 1,636
Default

I see pictures.
aidandj is offline  
Old 10-07-2016, 12:54 PM
  #48  
Elite Member
 
codrus's Avatar
 
Join Date: Mar 2007
Location: Santa Clara, CA
Posts: 4,516
Total Cats: 543
Default

Pictures are broken here.

--Ian
codrus is offline  
Old 10-07-2016, 02:47 PM
  #49  
Supporting Vendor
iTrader: (1)
 
Join Date: May 2010
Location: San Diego
Posts: 516
Total Cats: 54
Default

In light of this thread I just checked out last shipment of hubs. Out of 6 hubs we received 3 boxes that were made in Japan and 3 made in the USA.

Made in Japan hubs were assembled in 2015 and are correct:




Made in USA hubs were assembled in mid 2016 and are not good...now being exchanged. I also noticed the made in USA hubs have bearings which are not stamped.

__________________
Scooby: Rotrex powered 1992 NA6 - 240WHP/190TQ

Singular Motorsports

Last edited by Lincoln Logs; 10-07-2016 at 03:09 PM.
Lincoln Logs is offline  
Old 10-07-2016, 06:39 PM
  #50  
Junior Member
iTrader: (9)
 
Join Date: Dec 2011
Location: SFBay
Posts: 348
Total Cats: 40
Default

Originally Posted by hornetball View Post
No, from scenturion. It looks like he was trying to show a picture in his post.
I've seen this issue before. I am hosting the pics on google photos. Are you on mobile or the app? What browser are you using?
scenturion is offline  
Old 10-07-2016, 07:52 PM
  #51  
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,188
Total Cats: 656
Default

I'm on a regular PC using Firefox.
hornetball is offline  
Old 10-07-2016, 08:25 PM
  #52  
Elite Member
iTrader: (1)
 
turbofan's Avatar
 
Join Date: Sep 2010
Location: Laguna Hills, CA
Posts: 7,220
Total Cats: 628
Default

I could see them on a regular PC using Chrome, and also on my phone using Chrome.
turbofan is offline  
Old 10-07-2016, 11:52 PM
  #53  
Elite Member
 
codrus's Avatar
 
Join Date: Mar 2007
Location: Santa Clara, CA
Posts: 4,516
Total Cats: 543
Default

Safari on a mac won't render them. I loaded the page source and pulled down the images, they appear to be 'RIFF' files, which is some proprietary Windows format with god-only-knows what embedded in it.

--Ian
codrus is offline  
Old 10-08-2016, 02:14 AM
  #54  
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 18,495
Total Cats: 1,636
Default

Loads on Android, windows, and osx for me. All chrome.
aidandj is offline  
Old 10-08-2016, 08:16 AM
  #55  
Elite Member
 
codrus's Avatar
 
Join Date: Mar 2007
Location: Santa Clara, CA
Posts: 4,516
Total Cats: 543
Default

Originally Posted by aidandj View Post
Loads on Android, windows, and osx for me. All chrome.
Pics now render fine. Bizarre.

--Ian
codrus is offline  
Old 10-09-2016, 12:25 PM
  #56  
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,188
Total Cats: 656
Default

I've got the pictures now too. Good grief, that's fugly! And the hubs show the same faulty machining and stress points.
hornetball is offline  
Old 10-12-2016, 12:33 PM
  #57  
Supporting Vendor
iTrader: (1)
 
Join Date: May 2010
Location: San Diego
Posts: 516
Total Cats: 54
Default

Finally got the run down from some folks at Centric/Stoptech. NTN Japan only does ONE production run per year of the OEM hubs that are correctly machined on the back (likely who Timken was sourcing from as well). Centric ran out of stock on the NTN sourced hubs this year and switched to Timken as a substitute supplier which is why there was a change in between batches. It is very likely Timken is sourcing their latest batch of hubs from someone else as well. It will be at least a few months before the correct hubs will hit market again but the good news is the folks at Centric are contacting them now and making them aware of the failure point to avoid this in future batches.
__________________
Scooby: Rotrex powered 1992 NA6 - 240WHP/190TQ

Singular Motorsports
Lincoln Logs is offline  
Old 10-20-2016, 11:58 AM
  #58  
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: *** BANNED ***
Posts: 9,666
Total Cats: 998
Default

You guys just forced me to pop into my hub repack thread and grab a pic:



Well, I can breathe easier.

I added a link to this thread, but its all the way at the end. My thread is from 2013 and I can't edit it so I've requested mod assist for an edit. The more places we can get this information out the better!
EO2K is offline  
Old 10-20-2016, 12:08 PM
  #59  
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 3,031
Total Cats: 318
Default

Thanks G, now I'm 2nd guessing my recent timken replacement I had installed.
Girz0r is offline  
Old 10-20-2016, 12:14 PM
  #60  
Elite Member
iTrader: (1)
 
turbofan's Avatar
 
Join Date: Sep 2010
Location: Laguna Hills, CA
Posts: 7,220
Total Cats: 628
Default

Originally Posted by Girz0r View Post
Thanks G, now I'm 2nd guessing my recent timken replacement I had installed.
Not an issue since you're not tracking your car.
turbofan is offline  

Thread Tools
Search this Thread
Quick Reply: SM Weekend of Failure (wheel hubs)


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.