DIYPNP on 1997 miata - a little help - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-09-2012, 08:15 AM   #1
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default DIYPNP on 1997 miata - a little help

Hey,

Just got my DIYPNP finished and I hooked it to the car with a pro tuner help.

We wanted to see if all sensors are ok and maybe try to start the engine.

The car is stock.

1. TPS calibration detect only 1023 value.
2. The air sensor gives nothing (stock MAF)
3. The calibration value from
http://www.megasquirtpnp.com/docs/mspnp_g2_mm9697.htm
Gave -18C for the coolant, when we choose mazda from the drop down menu, it gave a normal value of 82C

4. Spark mode, my tuner would like to make sure the 4G63 is ok for my 1997 miata with two coil connectors 4 wires each.

Even the ECU location was different from the one in the instruction...

This is my ECU:



The white connector that is not connected, should I do anything with it ?

[/QUOTE]

I need to do that:


right ?

Do I need to enable IAC ?

Thanks !
Attached Thumbnails
DIYPNP on 1997 miata - a little help-img0555fk.jpg   DIYPNP on 1997 miata - a little help-4_cyl_wasted_spark.jpg  
elior77 is offline   Reply With Quote
Old 11-09-2012, 08:17 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

did you follow this when you built it?


DIYPNP MegaSquirt installation for the Mazda Miata
Braineack is offline   Reply With Quote
Old 11-09-2012, 08:33 AM   #3
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

Yes sir, I did.

The calibration values gave negative temps (in C)

My tuner would like to know is 4G63 is the right spark mode.

I understand the info is for a USDM miata... mine is not USDM...
elior77 is offline   Reply With Quote
Old 11-09-2012, 09:34 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

4G63 is correct, are you using the basemap?

What do you have a JDM or EUR? i wasnt aware of the wiring being different so unsure why the sensors arent inputting correctly for you.
Braineack is offline   Reply With Quote
Old 11-09-2012, 01:11 PM   #5
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

How can I tell if my car JDM or EUR ?

Just to get things clear,

I use this start maps :
http://www.diyautotune.com/diypnp/ap...97-18bp-mt.zip

And this settings:




Any thing else I need to do before trying to start the engine ?
Attached Thumbnails
DIYPNP on 1997 miata - a little help-capturedmg.png  
elior77 is offline   Reply With Quote
Old 11-09-2012, 03:59 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

not really no. but not having sensors read correctly might lead to it not wanting to start.
Braineack is offline   Reply With Quote
Old 11-10-2012, 04:06 AM   #7
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

Quote:
Originally Posted by braineack View Post
4g63 is correct, are you using the basemap?

What do you have a jdm or eur? I wasnt aware of the wiring being different so unsure why the sensors arent inputting correctly for you.

jdm
elior77 is offline   Reply With Quote
Old 11-05-2014, 03:35 PM   #8
Senior Member
Thread Starter
 
Join Date: Nov 2012
Location: Israel
Posts: 543
Total Cats: -298
Default

Wrong pin soldered for GND wire on ECU - fixed, all sensors ok.

*Just closing up all my threads with the solutions I found.
elior77 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:40 PM.