DIYPNP questions! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-27-2010, 03:38 PM   #1
Newb
Thread Starter
 
Join Date: Aug 2010
Location: Howard County, MD
Posts: 29
Total Cats: 0
Default DIYPNP questions!

Hello guys,

I bought a diypnp for my '99. I've got the board completely assembled (hopefully).

I followed the assembly instructions here: http://www.diyautotune.com/diypnp/do..._assembly.html

and the jumpers from here:
http://www.diyautotune.com/diypnp/ap...0-18bp-mt.html.

Do I not need a pull up on the ALED for VICS control?
Also is nothing needed for the VR in +&- connections?

I bought a voltage regulator and connector from NAPA- VR38SB. I'm not entirely sure where to connect it. Are the directions in this thread correct?
http://www.msextra.com/forums/viewto...26836&start=20. If they are could someone please give me a dummy explanation. I don't want to mess anything up.
Do I need to do anything on the board itself once I get the voltage regulator set up?

Besides loading firmware, installing AIT and MAP hose, is there anything I am missing or need to do before I put it in the car?

Thank you, and sorry for being a I know these questions are probably answered somewhere but I can't understand them sometimes.
jeremiahhh is offline   Reply With Quote
Old 10-27-2010, 03:41 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

1. no.
2. no.
3. one wire goes to ground, one to 12v, and one to 1O IIRC.
Braineack is offline   Reply With Quote
Old 10-27-2010, 03:54 PM   #3
Newb
Thread Starter
 
Join Date: Aug 2010
Location: Howard County, MD
Posts: 29
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
1. no.
2. no.
3. one wire goes to ground, one to 12v, and one to 1O IIRC.
Thanks,

Mine only has two leads on it. So ground the case I guess? Then hook the blue wire to +12v and the green one to the Red/grey wire coming off the alternator that goes to pin 1O.

Wheres the best spot to get the +12v from?

Oh, another quick question. Do I need to do anything to the diypnp physically when I install my lc-1?
jeremiahhh is offline   Reply With Quote
Old 10-27-2010, 04:01 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

oh yeah, only two, the box itself must be grounded FWIW.

https://www.miataturbo.net/showthrea...hlight=voltage


also remember 1O does not equal 1O as far as the DIYPNP is concerned. It might be 4O I can't remember. ill double check that one for you.



for wbo2, you must bring the input into the db15 and connect it to the o2 hole on the PCB.
Braineack is offline   Reply With Quote
Old 10-27-2010, 04:15 PM   #5
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

FWIW, the NAPA regulator never worked for me. 1O is still 1O on the DIYPNP.
Reverant is offline   Reply With Quote
Old 10-27-2010, 04:24 PM   #6
Newb
Thread Starter
 
Join Date: Aug 2010
Location: Howard County, MD
Posts: 29
Total Cats: 0
Default

Oh right, I figured it was 1O still cause the other regulation circuit gets jumped to 1O on the diypnp from the proto area. But I'll be fine if i just splice it right into the red/gray from off the alternator right?

So ill run the wbo2 in from the db15, then from that pin to the edge pin labeled o2?

Out of curiosity what happens if the alternator voltage is not regulated?

I'm hoping to get all this done tonight.. The wbo2 install, put ait in, and hook up the diypnp!
jeremiahhh is offline   Reply With Quote
Old 10-27-2010, 04:36 PM   #7
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

Quote:
Originally Posted by jeremiahhh View Post
Oh right, I figured it was 1O still cause the other regulation circuit gets jumped to 1O on the diypnp from the proto area. But I'll be fine if i just splice it right into the red/gray from off the alternator right?
Yes

Quote:
Originally Posted by jeremiahhh View Post
Out of curiosity what happens if the alternator voltage is not regulated?
Battery voltage.
Reverant is offline   Reply With Quote
Old 10-27-2010, 04:36 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

battery doesn't charge and you get sad face when car dies and you get stranded.

if it's working and car is running, voltage should stay steady at 14v.
Braineack is offline   Reply With Quote
Old 10-27-2010, 05:50 PM   #9
Senior Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Sweden
Posts: 1,391
Total Cats: 58
Default

If you have not read it yet
https://www.miataturbo.net/megasquirt-18/99-diypnp-1-5-build-comments-questions-48516/
It might have some useful info (unless it confuses things).
Making the Alt Regulator yourself is not that hard, and its 1O, where mine have done the job nicely the whole summer.
NiklasFalk is offline   Reply With Quote
Old 10-28-2010, 11:55 AM   #10
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,264
Total Cats: 51
Default

Quote:
Originally Posted by Braineack View Post
battery doesn't charge and you get sad face when car dies and you get stranded.

if it's working and car is running, voltage should stay steady at 14v.
I seem to recall another thread where the opposite happened: The voltage went to 18 volts and damaged everything.
Matt Cramer is offline   Reply With Quote
Old 10-28-2010, 12:12 PM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

maybe that.
Braineack is offline   Reply With Quote
Old 10-28-2010, 01:14 PM   #12
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 197
Default

Having tried it myself a few times and in different configurations: no current from the alternator.
Reverant is offline   Reply With Quote
Old 10-28-2010, 07:17 PM   #13
Newb
Thread Starter
 
Join Date: Aug 2010
Location: Howard County, MD
Posts: 29
Total Cats: 0
Default

I didn't get to do it last night, but I'm gonna do it all tomorrow. I'll just shoot for doing it the right way so I don't have to deal with any of those problems .

NiklasFalk, I've read your thread a few times actually hah. Someone mentions that only the oem ecu understands the knock signal. So is it recommended to get an after-market one at least when I turbo?
jeremiahhh is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:38 AM.