Help tracking down MS3 wiring issues/diagram - Page 6 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-27-2014, 09:28 AM   #101
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

OK, wired up the Vic's connector and pulled the wiring through the firewall to get it ready for the DB12 connector.



EBC got wired as well. Connected to the blue +12v switched sitting right behind the drivers headlight. Pulled the DB12 wire through the firewall





Connector off of 2&4 are what I'm guessing is going to the DB12. I'm going to change that so it is a little cleaner.





The small single pin wire goes to the Rear thermostat(I think?) or it is the CAS wire.

Attached Thumbnails
Help tracking down MS3 wiring issues/diagram-img_2412.jpg   Help tracking down MS3 wiring issues/diagram-img_2421.jpg   Help tracking down MS3 wiring issues/diagram-img_2416.jpg   Help tracking down MS3 wiring issues/diagram-img_2415.jpg   Help tracking down MS3 wiring issues/diagram-img_2419.jpg  


Last edited by Jeffbucc; 03-27-2014 at 09:44 AM.
Jeffbucc is offline   Reply With Quote
Old 03-27-2014, 09:37 AM   #102
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

NO. stop. **** you.

you dont just put flyback diodes wherever you damn well please.

where has anyone ever suggested you should put diode on the injectors?

again: **** you.



And of course your oem 1.6L had the injectors paired correctly. the problem is you want to REMOVE the pairing and rewire it so you can run sequential injection, same thing with your cop harness. also that harness looks like complete garbage.
Braineack is online now   Reply With Quote
Old 03-27-2014, 09:43 AM   #103
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

Quote:
Originally Posted by Braineack View Post
NO. stop. **** you.

you dont just put flyback diodes wherever you damn well please.

where has anyone ever suggested you should put diode on the injectors?

again: **** you.

And of course your oem 1.6L had the injectors paired correctly. the problem is you want to REMOVE the pairing and rewire it so you can run sequential injection, same thing with your cop harness. also that harness looks like complete garbage.
Oh **** you were talking about the COP. That was a sleep deprived mix up dude. Apologies. Yeah the harness is disgusting.

No not **** me. I have been awake for a while. Editing now!
Jeffbucc is offline   Reply With Quote
Old 03-27-2014, 09:47 AM   #104
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

And it's not like I was just going to vomit diodes on to it, I would have quadruple checked to see if I was making an idiot mistake.
Jeffbucc is offline   Reply With Quote
Old 03-27-2014, 09:50 AM   #105
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

MS3X pro-tip-of-the-day:

the expander board was built with a sub-par flyback circuit for it's PWM outputs.

That comprises: boost, idle, nitrous2, nitrous1, vvt, and tacho.

You only need to add a flyback diode to 12v on any PWM device that's on one of those outputs. In your case that's Boost and Idle like I suggested.

You do not need to add a diode in any other case, unless you're also running VVT.
Braineack is online now   Reply With Quote
Old 03-27-2014, 09:51 AM   #106
Senior Member
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

Green connector goes to the water temp sender for the ECU at the rear of the head.

single black/blue - goes to the water thermosensor for the instruments cluster...
Zaphod is offline   Reply With Quote
Old 03-27-2014, 09:57 AM   #107
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

Thanks for clearing that up Brain.

I had them connected Zaph just wasn't sure what their function was, appreciated.

I think, besides needing new connectors for the 99 throttle body, we are getting pretty close to getting it sorted.

You guys have the patience of saints, brain just likes to kick me in the nuts politely before he educates me...which works super effectively!
Jeffbucc is offline   Reply With Quote
Old 03-27-2014, 09:59 AM   #108
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

im just in a bad mood.
Braineack is online now   Reply With Quote
Old 03-27-2014, 10:04 AM   #109
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

Quote:
Originally Posted by Braineack View Post
im just in a bad mood.
Its cool man, I don't let **** get to me at all. I'd rather admit my ignorance and solve the problem rather than letting my pride get in the way.

The weekend is just around the corner!
Jeffbucc is offline   Reply With Quote
Old 03-27-2014, 10:16 AM   #110
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

I'm the embrace that smothers.
Braineack is online now   Reply With Quote
Old 03-27-2014, 11:02 AM   #111
Senior Member
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

Quote:
Originally Posted by Jeffbucc View Post
brain just likes to kick me in the nuts politely before he educates me...which works super effectively!
Well I can do that too, but I prefer that in a more physical way...

You just got me on the hook with your project and I like to see that thing finished... (Though I don't want to see it driven, because it might break my heart...)
Zaphod is offline   Reply With Quote
Old 03-27-2014, 03:13 PM   #112
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

Quote:
Originally Posted by Zaphod View Post

Well I can do that too, but I prefer that in a more physical way...

You just got me on the hook with your project and I like to see that thing finished... (Though I don't want to see it driven, because it might break my heart...)
Nah, no hook Zaphod. Never feel obligated to help!
Jeffbucc is offline   Reply With Quote
Old 04-07-2014, 09:17 AM   #113
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

OK, a couple questions. Which wire do you splice into for the Tach Out pin for 2B on the DB12 connector? Is it from the Tach wire on the COP Mitsubishi Power Unit?

Also, is the passenger side motor mount sensor the knock sensor along with a 2 pin wire, located below the lower intake manifold? I believe the principle owner said he had 2 knock sensors hooked up to the car.

Also, as per a previous post I found of yours Brain, are these are the correct wires to make the new VTPS connector be recognized by the MS?

Quote:
connect the TPS signal wire for the MS to 2L
connect the 5vref signal wire for the MS to 1N
Jeffbucc is offline   Reply With Quote
Old 04-08-2014, 02:46 PM   #114
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

Ok ONE last question. the 2 +12v and ground for 2E 2C 2A, are these to power the breakout board or are they additional pins for things to be added to the connector?

Just need to know if I need to run wires for power and ground to the breakout board or if they are supplied via the main Megasquirt board.
Jeffbucc is offline   Reply With Quote
Old 04-08-2014, 03:05 PM   #115
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

they are used for that fuel pump curcit that's built there, plus additional points to send to the spare connector.
Braineack is online now   Reply With Quote
Old 04-08-2014, 03:12 PM   #116
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

OK so just leave them alone And good to go?

Sorry I've been up for 2 days and the brain(my brain) needs clarification.
Jeffbucc is offline   Reply With Quote
Old 04-08-2014, 03:39 PM   #117
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

Braineack is online now   Reply With Quote
Old 04-08-2014, 03:51 PM   #118
Elite Member
Thread Starter
 
Join Date: Oct 2013
Location: Cedar City, UT
Posts: 2,769
Total Cats: 948
Default

Praise Oprah! Best news all day long.
Jeffbucc is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:22 AM.