Idle issues after installing 550cc injectors MS3x - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-28-2013, 10:08 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2013
Location: Baltimore, MD
Posts: 76
Total Cats: 0
Default Idle issues after installing 550cc injectors MS3x

See attached tune and data log

The car starts and idles but idles rich and likes to drop way below 850rpm.

I have tried to figure out the injector dead time... but I bought some cheap ones off ebay that didn't give any of that info.

They are rebuild denso 550cc's.. but besides that... I don't know much more.

I have also tried playing with the accel pump settings...
Attached Files
File Type: msq 2013-03-28_21.05.36.msq (160.9 KB, 39 views)
File Type: msl 2013-03-28_20.49.02.msl (1.99 MB, 45 views)
palmerino17 is offline   Reply With Quote
Old 03-29-2013, 10:13 AM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,264
Total Cats: 51
Default

Are they high or low impedance?
Matt Cramer is offline   Reply With Quote
Old 03-29-2013, 10:30 AM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2013
Location: Baltimore, MD
Posts: 76
Total Cats: 0
Default

High impedance
palmerino17 is offline   Reply With Quote
Old 03-29-2013, 11:06 AM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

RX-7 or RC injectors?
Reverant is offline   Reply With Quote
Old 03-29-2013, 11:09 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

were these injectors cleaned? old rx7 injectors? going by your fuel map, it looks like you're barely injecting fuel at idle.


yeah. 1.6ms at idle is probably as fast as these can cycle, and youre still at 11.0:1. either the AFR settings are bad, or one or two or three or four of these are just dumping in fuel at idle.
Braineack is offline   Reply With Quote
Old 03-29-2013, 11:29 AM   #6
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Braineack View Post
were these injectors cleaned? old rx7 injectors? going by your fuel map, it looks like you're barely injecting fuel at idle.


yeah. 1.6ms at idle is probably as fast as these can cycle, and youre still at 11.0:1. either the AFR settings are bad, or one or two or three or four of these are just dumping in fuel at idle.
I easily idled at 14.7 on MS1 batch with EV1 550s that flowed 580.
hustler is offline   Reply With Quote
Old 03-29-2013, 12:18 PM   #7
Junior Member
Thread Starter
 
Join Date: Feb 2013
Location: Baltimore, MD
Posts: 76
Total Cats: 0
Default

Here is the link to the injectors

Mazda Miata 1 8L Set of 4 550cc Direct Fit Fuel Injectors | eBay

I'm beginning to regret buying them
palmerino17 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:54 AM.