Please HELP W/ MAC & WINDOWS & Megatune - Page 6 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-06-2008, 03:44 AM   #101
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

ur a friggin savior...didnt think anyone was on...

I just caught up soooorrrry I missed the 1.5 thing, but I did see the osx reqmnts on the site...and like u realized no luck....

The x11 opens to something that says xtherm...then its like a prompt, looks alot like terminal?

Dunno how else to check,,,i dont see it on finder/hd/etc

PS--darwinports also installed....IT said 10.4 as well, but installed without an issue...there's no icon or anything for that right?? kind alike a hidden program or something?---I ask cuz it went thru the whole install, "success" screen, etc...but i dont see anything to actually run
TonyV is offline   Reply With Quote
Old 02-06-2008, 03:47 AM   #102
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

i looked trhough my collection of CD's and i found my old copy of Xcode 1.0. its for 10.3. (yes its the official CD). Shoot me a MSG if you want the copy.
Marc D is offline   Reply With Quote
Old 02-06-2008, 03:48 AM   #103
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

X11 does look like terminal, sounds like that is working then.
I'll see if i have xcode 1.5 as well. Might be here somwhere.
cjernigan is offline   Reply With Quote
Old 02-06-2008, 03:49 AM   #104
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

Quote:
Originally Posted by tvalenziano View Post
ur a friggin savior...didnt think anyone was on...

I just caught up soooorrrry I missed the 1.5 thing, but I did see the osx reqmnts on the site...and like u realized no luck....

The x11 opens to something that says xtherm...then its like a prompt, looks alot like terminal?

Dunno how else to check,,,i dont see it on finder/hd/etc
im up all night studying. students dont sleep :(. well not here at least haha.

xtherm is right. thats the interface your introduced to when you first open it, it looks like a DOS prompt doesnt it? its generally a UNIX virtual system. did you try installing Megatunix yet? if that doesnt work, you need to get all the libraries needed. im sure you dont have any of them yet.

check out the megatunix website. use Fink to download all those stupid libraries you need. you need to download version 0.7.2, the one compatible with panther.

http://www.macports.org/ go to this website and download the version specific for panther, i.e. 10.3

after that, follow everything on this thread here. it tells you all the commands to use. you might get away with installing those libraries, it seems he found a new way to install the libraries without having to deal with too much trouble like i had when it first was just being tinkered to work on a mac.

http://www.msextra.com/viewtopic.php?t=23434
Marc D is offline   Reply With Quote
Old 02-06-2008, 03:53 AM   #105
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

i didnt try installing megatunix bc i wanted to make sure i got everything installed...

still unsure bout the xcode...it was mentioned that its needed to run x11?? if i have it running can i move on now or still need to install??

Also, fyi the tunix install instructions say xcode 2.4, dunno if it matters...
TonyV is offline   Reply With Quote
Old 02-06-2008, 03:54 AM   #106
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

it says xcoe 2.4 BECAUSE his computer is updated with Tiger. yours isnt.

it looks like you can run it without Xcode, but if you were going to try to run an application on the X11, it wont seem like you would get far because of (im repeating myself for the 32487329572 time) the lack of libraries to run those applications.

Xcode installs the basics of the ability to run applications on X11
Marc D is offline   Reply With Quote
Old 02-06-2008, 03:58 AM   #107
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

Just installed the proper macports (same result as darwinport install)

Im sorry but i only remember hearing that there's thousands of libraries...didnt remember anythign specific other than do what the tunix instrutions say...?
TonyV is offline   Reply With Quote
Old 02-06-2008, 04:02 AM   #108
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

i said that whole deal about the thousand libraries because its true. theres an overwhelming amount. if you were to use Fink to download every single one thats required to run megatunix, youd be downloading for WEEKS. Ask me how i know.

Theres a reason why he said "set the install up for the libraries (libgib or whatever) then work on your car or do something else. It will take 1-6 hours to dl depending on your speed."

I had to fish out each and every one of those libraries until he discovered this new way to do it.

Like i said earlier, it seems he found a new way to install all that crap. He even mentions how bad Fink is, but its much easier to use in the end because the ability to uninstall it later. The way i was trying to do it was when people were just beginning to tinker on the X11 to try and make Megatunix work on the mac. (I was planning to megasquirt my AE86 when i still had it, then i scrapped the idea. this was 2 years ago)
Marc D is offline   Reply With Quote
Old 02-06-2008, 04:08 AM   #109
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

try and follow his installation procedures, even without the Xcode. let us know what happens. Download Fink. the worst that could happen is that Fink wont even open because Xcode isnt there.
Marc D is offline   Reply With Quote
Old 02-06-2008, 04:09 AM   #110
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

ok, think its doing what ur saying, on its own??

http://www.msextra.com/viewtopic.php?t=23434

Theres the inst. again...

I just did the part where it says to type those 2 commands in the terminal...
Then all of a sudden it started going thru what seems like thousands of commands...it was the self update..thats done and said successfully..

Now trying to get the 2nd command going...I entered the text, hit enter key but nothing...
TonyV is offline   Reply With Quote
Old 02-06-2008, 04:11 AM   #111
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

Quote:
Originally Posted by badboy88000 View Post
try and follow his installation procedures, even without the Xcode. let us know what happens. Download Fink. the worst that could happen is that Fink wont even open because Xcode isnt there.
Not to debate cuz u know alot more than me...but the instructions were made to supposedly avoid fink and make a much easier install??
MAYYYBE these command prompts take the Fink/libraries out of the equation somehow...or automatically do them in 1 command??
TonyV is offline   Reply With Quote
Old 02-06-2008, 04:19 AM   #112
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

yea youre right. i read too quickly

Dont use Fink then. but that still doesnt mean you have the necessary libraries. How would it update libraries that arent even there? thats where Xcode comes into play.
Marc D is offline   Reply With Quote
Old 02-06-2008, 04:19 AM   #113
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

Ok it encountered an error on the 2nd command...
(copy paste from terminal screen--tried it twice and same result)
Is this the xcode issue?? or somethign else?? dunno if the actual wording of the rror means anything soooooo here it is...
Im bout to pass out...


Last login: Wed Feb 6 03:11:36 on ttyp1
Welcome to Darwin!
admins-Computer:~ admin$ sudo port install gtkglext libglade2
Password:
---> Configuring expat
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org _release_ports_textproc_expat/work/expat-2.0.1" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man " returned error 77
Command output: checking build system type... powerpc-apple-darwin7.9.0
checking host system type... powerpc-apple-darwin7.9.0
checking for gcc... /usr/bin/gcc-3.3
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

Error: The following dependencies failed to build: gtk2 atk gettext expat libiconv gperf ncurses ncursesw glib2 pkgconfig cairo fontconfig freetype zlib libpng render xrender cups-headers gtk-doc docbook-xml-4.1.2 xmlcatmgr docbook-xsl libxml2 perl5.8 scrollkeeper docbook-xml docbook-xml-4.2 docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 libxslt p5-xml-parser jpeg pango Xft2 xorg-xproto xorg-util-macros tiff
Error: Status 1 encountered during processing.
TonyV is offline   Reply With Quote
Old 02-06-2008, 04:28 AM   #114
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

^^ thats the errors you get if you dont have Xcode.
Marc D is offline   Reply With Quote
Old 02-06-2008, 04:38 AM   #115
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

So is there anyway to get xcode other than a physical disk???
Im guessing after this hurdle it may get a lil easier considering the libraries hunting portion is cut out of the equation...

I gotta get some sleep...stayed at it as long as i could but gonna have to continue tomm..

Please tell me there's a solution other than physically having to get xcode off a disc...wanna se some good news here when i get up tomm!! jk

ps--thanks for all ur help so far!
TonyV is offline   Reply With Quote
Old 02-06-2008, 04:38 AM   #116
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

reading through the thread, you might actually be able to get away with using Fink without installing Xcode, but it requires you to follow close instructions on installing Fink. seems more of a hassle than to just install Xcode.
Marc D is offline   Reply With Quote
Old 02-06-2008, 04:43 AM   #117
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

doesnt seem there is any other way besides a physical disk. Most people dont even use panther (i digress) and people update to 10.4 tiger. Due to some circumstances on my other computer (450 mhz G4 tower) its still using 10.3.9 and my 1ghz G4 powerbook is using jaguar... (10.2) lol.

so theres 3 things you can do from here.
1. Get Xcode somehow, someway. (I got the CD in my hands)
2. Update to Tiger
3. Use Fink with hours and hours of moaning and groaning.
Marc D is offline   Reply With Quote
Old 02-06-2008, 11:30 AM   #118
Senior Member
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default Virtual PC

VPC is the way to go man. I'm running this on a G4 iBook and it works fine. A little slow but overall OK. Best if you can install a 'lite' copy of XP though. Runs a little quicker.
soloracer is offline   Reply With Quote
Old 02-06-2008, 11:30 AM   #119
Senior Member
iTrader: (7)
 
Join Date: Jul 2007
Location: Milpitas, CA
Posts: 1,057
Total Cats: 1
Default

to see if that actual method worked, i tried to install megatunix myself.

feels like im going through the same **** over again.
im installing all these libraries.
and it still says i need one after i downloaded all of them "supposedly." megatunix wont make to completion, and wont install fully because the lack of those ****** libraries.

the damn thing compiles just fine, but when you get to the make command, you get thrown a bunch of errors messages at the end.

it wont work with my computer and i dont want to go through the trouble of figuring it out how to make it work, so im sticking with BootCamp. youre own your own from here.
Marc D is offline   Reply With Quote
Old 02-06-2008, 11:32 AM   #120
Senior Member
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default If you get frustrated...;p

and decide to ditch that Mac, let me know. I might be able to come up with a laptop to trade ya.
soloracer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
First gen (white) megasquirt pnp 90-93 Miata firmware reflash Johnny Tater MSPNP 1 09-27-2015 01:38 AM
DIYPNP problem PA0 VICS output spidy MEGAsquirt 7 09-24-2015 04:14 PM
Black hardtop, Los Angeles thebeerbaron Miata parts for sale/trade 2 09-24-2015 04:16 AM
Microsoft Edge browser & MT.NET bahurd Front Desk 0 09-21-2015 09:45 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:14 PM.