Take a look at my board. Help me sort and prep my MS. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-11-2008, 03:56 PM   #1
Senior Member
Thread Starter
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default Take a look at my board. Help me sort and prep my MS.

Just wanting the gurus and others more experienced than I to look at my board and advise on a couple of issues.

This is a Braineak build but I believe this was an early one. It was also built for a 1.6 and I’m using it on a 1.8. We’ve discussed it but not in detail and I feel like I’m being a pest so I’m putting it out here for help.

First – Going through Brain’s “how to”, there’s a pic that shows the spark outputs reversed from the graphic. He noted not to duplicate his but my board matches his photo, not the graphic. So I’m wondering if I should leave mine as is or reverse it.

Graphic:
Take a look at my board. Help me sort and prep my MS.-ms1_v3_msns-e_miata_input_and_output_mods.jpg


Scott’s pic:
Take a look at my board. Help me sort and prep my MS.-msmods006.jpg


My board:
Take a look at my board. Help me sort and prep my MS.-msbck.jpg


Second – My board does not have the .1µF capacitor on the tach input circuit from JS8 to ground. Should I add this? If so, can I use the same ground pin as the EBC MOSFET?


Third – I’m pretty certain the LEDs are backwards, no?
Take a look at my board. Help me sort and prep my MS.-leds.jpg


I also have a 100k resistor on the EBC (@ JS2), so I need to change this to a 100 ohm and add a mica insulator on the IRLZ44. Right? Do I need to re-attach the MOSFET with a nylon screw or will the metal one still be OK? It's mounted to the front of the case.

Lastly – I believe I need to add a diode for the idle mod. What diode do I use? I’m planning a parallel install for now so I suppose it doesn’t matter, but I’d just as soon do it now while I’m monkeying about with it.
Take a look at my board. Help me sort and prep my MS.-ebcidle.jpg

Whew! Thanks for takin’ a look. Once this is sorted I guess it’s on to the parallel harness changes. THAT should be interesting……

Last edited by soloracer; 08-11-2008 at 05:45 PM. Reason: Giant pics
soloracer is offline   Reply With Quote
Old 08-11-2008, 04:07 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

Quote:
First – Going through Brain’s “how to”, there’s a pic that shows the spark outputs reversed from the graphic. He noted not to duplicate his but my board matches his photo, not the graphic. So I’m wondering if I should leave mine as is or reverse it.
leave them alone if you are using the harness I built as well.

Quote:
Second – My board does not have the .1µF capacitor on the tach input circuit from JS8 to ground. Should I add this? If so, can I use the same ground pin as the EBC MOSFET?
add it if you plan on using hi-res 10g firmware.

Quote:
Third – I’m pretty certain the LEDs are backwards, no?
they are; snip them, flip them, solder them back.


Quote:
I also have a 100k resistor on the EBC (@ JS2), so I need to change this to a 100 ohm and add a mica insulator on the IRLZ44.
correct.

Quote:
Right? Do I need to re-attach the MOSFET with a nylon screw or will the metal one still be OK? It's mounted to the front of the case.
yes, that's the EBC IZ144 FET...that needs an insulator as well, you can use the metal screw if the rubber gasket thing is there.


Quote:
Lastly – I believe I need to add a diode for the idle mod. What diode do I use? I’m planning a parallel install for now so I suppose it doesn’t matter, but I’d just as soon do it now while I’m monkeying about with it.
you actually can put a diode on both those the Idle and EBC FETs right there on the board. stripe side to s12, then on to each of the middle legs of the FETs.

like this:



any 1A diode should work

http://www.radioshack.com/product/in...Id=2062589&cp=
Braineack is online now   Reply With Quote
Old 08-11-2008, 04:11 PM   #3
Junior Member
 
Join Date: Aug 2007
Posts: 115
Total Cats: 0
Default

Follow the DIY guide as far as spark goes.
You need the capacitor on the tach signal if you want to run the Hi-res code.

Not so sure on teh EBC stuff, but if you are insulating it with mica for the love of god don't un-insulate it with a metal screw.

For the idle stuff, you can probably get away with just about any power diode (think 1n4001, 1n4004, 1n5404, etc.).

or

word on what Braineak said
yertnamreg1218 is offline   Reply With Quote
Old 08-11-2008, 04:20 PM   #4
Senior Member
Thread Starter
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default

Quote:
...you actually can put a diode on both those the Idle and EBC FETs right there on the board. stripe side to s12, then on to each of the middle legs of the FETs."
Cool. One diode for each FET or share 1 for both?

Thanks Brain!

Quote:
Originally Posted by yertnamreg1218 View Post

Not so sure on teh EBC stuff, but if you are insulating it with mica for the love of god don't un-insulate it with a metal screw.
Yeah, that's why I asked. Seemed weird that it needed insulated but was attached with a metal screw! I'll change it.

Quote:
For the idle stuff, you can probably get away with just about any power diode (think 1n4001, 1n4004, 1n5404, etc.).
Thanks! I may have some old 1n4001s laying around....

Last edited by soloracer; 08-11-2008 at 04:22 PM. Reason: stupid me left out quote tag!
soloracer is offline   Reply With Quote
Old 08-11-2008, 04:26 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

1 for each.

regarding the EBC. when I first started doing them, DIY didn't send them with any insulators and I had no clue they needed them. The resistor was their mistake as well as the package was actually labeled 100ohms but had 100k ohm resistors instead.
Braineack is online now   Reply With Quote
Old 08-11-2008, 04:36 PM   #6
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Dont use a metal screw on the fet, trust me. It does not help. swap for nylon with one from the map sensor.
Saml01 is offline   Reply With Quote
Old 08-11-2008, 04:42 PM   #7
Senior Member
Thread Starter
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default

Quote:
Originally Posted by Braineack View Post
1 for each.

regarding the EBC. when I first started doing them, DIY didn't send them with any insulators and I had no clue they needed them. The resistor was their mistake as well as the package was actually labeled 100ohms but had 100k ohm resistors instead.
Yeah, I know. I remember reading that. Didn't mean to try and sully your name or anything!

Any thoughts on what I need to do with that harness?

Also, what's the diode on the EBC for?
soloracer is offline   Reply With Quote
Old 08-11-2008, 04:47 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

same reason it's on the idle valve...the prevent voltage spikes and whatnot.

for the harness...you can compare the two diagrams and see where you need to move wires...it's not many..

injector wires need to be split to 2Y and 2Z
TPS input should be added
Probably want to connect all four ground spots (2A, 2B, 2C, 2D)
fuel pump ground to 2T


that should be it, not much is different.
Braineack is online now   Reply With Quote
Old 08-11-2008, 04:51 PM   #9
Senior Member
Thread Starter
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default

Awesome! Maybe I WILL get this thing in before the summer is over!
soloracer is offline   Reply With Quote
Old 08-12-2008, 11:25 AM   #10
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Quote:
Originally Posted by Braineack View Post
add it if you plan on using hi-res 10g firmware.
For the record, all firmware versions can benefit from the cap mod. We discovered the benefits from the cap mod while hunting down a misfire issue with regular MS1/Extra, and it's been standard on the MSPNP ever since.
Matt Cramer is offline   Reply With Quote
Old 08-15-2008, 12:25 AM   #11
Senior Member
Thread Starter
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default

OK. All updates, revisions, corrections, complete on the board. The harness awaits...

I have one question about the diodes for idle and EBC. I tied the banded ends together and soldered to the board (ran the other side to the center legs of the FETs). I assume this is ok?
soloracer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
New M62 Miata owner Pist0n Meet and Greet 4 10-01-2015 09:18 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:13 PM.