IAT wiring at ECU - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 05-07-2010, 08:43 PM   #1
Senior Member
Thread Starter
iTrader: (8)
 
paNX2K&SE-R's Avatar
 
Join Date: Dec 2007
Location: Mocksville, NC
Posts: 676
Total Cats: 11
Default IAT wiring at ECU

I'm doing the switch from the maf to the iat and I want to connect it at the ecu end instead of the maf harness end. After some searching is appears the orange iat wire goes to 2P (red/black?) and the black iat wire to either 2C or to 2D (not sure which).
paNX2K&SE-R is offline   Reply With Quote
Old 05-08-2010, 01:57 PM   #2
Newb
 
Join Date: Apr 2010
Posts: 2
Total Cats: 0
Default

Doesn't matter what two wires the sensor uses, i mean there isn't a correct polarity. Secondly both 2c and 2d are the same ground at jc-02 according to my diagram.
I just chopped off the plug at the MAF end, soldered the wires and heat shrinked the bare connections.
Whipit is offline   Reply With Quote
Old 05-08-2010, 02:52 PM   #3
Senior Member
Thread Starter
iTrader: (8)
 
paNX2K&SE-R's Avatar
 
Join Date: Dec 2007
Location: Mocksville, NC
Posts: 676
Total Cats: 11
Default

Yes it doesn't matter which is used for power and ground on the sensor. I just decided to stick with black wire as ground. I ended up using 2P (red/black) at the ecu connector for the orange wire and 2C (blue? have to look at the color again) for the black wire. I used a continuity tester and found these were the wires that went to pin 3 and 4 of the maf/afm plug.

I also found this pinout diagram useful:

paNX2K&SE-R is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:00 PM.