MSPNPpro MSM questions - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 04-15-2015, 12:40 PM   #1
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default MSPNPpro MSM questions

First off, I apologize for the number of threads in the mspnp section, 5 on the first page alone! I promise I know what I'm doing, and they're all from different projects!

I'm making this thread to keep Vlad's clean, and to post questions about my build. Build thread can be found in the build thread section.

Today, after driving it to work (fully warmed up), idle was at 1150rpm, instead of the target 950. Valve was not going below 18%, even when the minimum was set to 15%. If I lowered the closed valve minimum, it would lower the idle, so it's trying to get to 950, the settings are just limiting the software some how. It never got closer than 3-4% above the minimum. AC was off, and I wasn't set to defrost. Is there some other setting that I'm missing?

Don't worry, I'll have more questions later.
curly is online now   Reply With Quote
Old 04-15-2015, 12:45 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,895
Total Cats: 1,792
Default

was it colder today than normal?

there's a min valve duty and also a min CL duty.
Braineack is offline   Reply With Quote
Old 04-15-2015, 01:38 PM   #3
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

Yeah, air temp was colder than it's been, but I figure after a 25 minute drive, with coolant temp at 195ish, the AITs wouldn't be below what they've seen before.

So under idle control, there's a min valve duty? I browsed briefly, but didn't see it. Had to get to work. It was going below 18%, but only when I would lower the CL min. Seems like it was 4% off all the time.
curly is online now   Reply With Quote
Old 04-15-2015, 05:46 PM   #4
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Couple things:

How did you find the min and max values.

What is your I and P value in the PID.

With a PID you can have a case where with no I it never gets to the target. I ran into it when tuning boost control, and read about it but now can't find the link.

http://www.expertune.com/tutor.aspx
aidandj is offline   Reply With Quote
Old 04-15-2015, 07:02 PM   #5
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

Idle/crank settings, closed loop idle settings. It's closed duty and open duty, first two values in the upper left iirc. I'd have to look up the P and the I.
curly is online now   Reply With Quote
Old 04-15-2015, 07:04 PM   #6
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

I mean what did you use to determine your correct values.

The right way to do it is to go into test mode and start at 0% and increase until it starts to make a difference in idle. That is your min number.

Then start at 100% and lower until it makes idle drop. That is your max number.
aidandj is offline   Reply With Quote
Old 04-15-2015, 07:05 PM   #7
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

Yup. Except I haven't done max yet. But I don't care about that.
curly is online now   Reply With Quote
Old 04-15-2015, 07:06 PM   #8
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Weird. Might be PID tuning.
aidandj is offline   Reply With Quote
Old 04-15-2015, 09:24 PM   #9
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

Well my confusion comes from min value, and why TS is only outputting 4% above whatever my min is set to. It should go directly to my min if it's above the target idle, unless it finds the target before my min, which it didn't.
curly is online now   Reply With Quote
Old 04-15-2015, 09:27 PM   #10
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Ahh but see the ms uses PID to drive the output to the target rpm. But sometimes with an improper tuned PID that won't happen.


Or its some other problem...
aidandj is offline   Reply With Quote
Old 04-18-2015, 12:28 PM   #11
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

Next set of questions:

I want to enable internal SD logging and boost control table switching. I can see how to setup both settings, however I really only have the rear connector available, shown here:



Here are my drop down menu options for ebc switching:



And for SD logging:



Do you see my problem? None of the drop down menu choices correlate with the rear connector. I can use "digital in 4", but that's being used by AC idle up. Same goes for digital freq. In 2(VSS) and 3(charge lamp).

If I do disable AC idle up, and enable either SD logging or EBC table switching to digital in 4, how do I start either of these? I've tried a simply touching the wire to a ground, but that's not working either.

I guess there's a lot of MSextra forum reading I can do, but no where in the documentation for the MSpro does it say "in order to use these features you need to do this-".

Please advise.
Attached Thumbnails
MSPNPpro MSM questions-msmpro%2520rear%2520connector_zps3mty77u8.jpg   MSPNPpro MSM questions-msmpro%2520ebc%2520switch%2520options_zpseiveqavq.jpg   MSPNPpro MSM questions-msmpro%2520sd%2520log%2520options_zpsfkptxg70.jpg  
curly is online now   Reply With Quote
Old 04-18-2015, 01:58 PM   #12
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

There's only a certain number of digital inputs. Once you're out you're out. Also touching a wire to ground should be all you need. Make sure its a good ground that your touching it too. I spliced into the ecu ground.
aidandj is offline   Reply With Quote
Old 04-18-2015, 06:40 PM   #13
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

So all msms came with AC as far as I know. Does that mean I habe zero inputs unless I disable AC idle up?
curly is online now   Reply With Quote
Old 04-19-2015, 12:46 PM   #14
Cpt. Slow
Thread Starter
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,108
Total Cats: 518
Default

Quote:
Originally Posted by curly View Post
Does that mean I habe zero inputs unless I disable AC idle up?
Anybody?

I think I can use Digital In 2, although it's labeled that in the MSM pdf, I think the same is Digital Switched In 2, small change, but caught me off guard.

So I'll ground that to use it for table switch, however I'd like to enable the data logging as well. I could use the 12v from pin J for Digital 12v switched, but where is the digital 12v input?? The menus not matching the PDF table is really aggravating.
curly is online now   Reply With Quote
Old 04-19-2015, 05:39 PM   #15
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,895
Total Cats: 1,792
Default

on idle settings, there a closed idle valve duty % and then a min PID duty %.

maybe you need to back your idle speed screw in a bit to lower the idle speed at the lowest duty. My range was between 600rpm and 2500rpm and ran flawlessly.

there should be three digital switched ins--i usually set them up for: a/c input, VSS, and launch control.
Attached Thumbnails
MSPNPpro MSM questions-names_match.jpg  
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:19 PM.