Installing Shanghai-S kit tomorrow..help? - Page 8 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-25-2012, 10:50 PM   #141
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by shuiend View Post
How did you burp your coolant? I am betting you have air trapped in your system. You then need to order one of these. Use it to burp your coolant and the over heating problem will go away. Also putting the undertray back on will help with cooling.
I'll drain my radiator and put new coolant.
AdoboMiata is offline   Reply With Quote
Old 08-25-2012, 11:26 PM   #142
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Quote:
Originally Posted by AdoboMiata View Post
I'll drain my radiator and put new coolant.
You don't have to drain and refill. Jack up the front of your car as high as you can. Remove the radiator cap and then start the car. Let the engine warm up until the fan turns on and off. Refill the radaitor as coolant level goes down. Repeat letting the fans turn on and off two more times. During this time also watch temp gauge and make sure it is staying about 11-12oclock.
shuiend is offline   Reply With Quote
Old 08-26-2012, 01:31 AM   #143
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by shuiend View Post
You don't have to drain and refill. Jack up the front of your car as high as you can. Remove the radiator cap and then start the car. Let the engine warm up until the fan turns on and off. Refill the radaitor as coolant level goes down. Repeat letting the fans turn on and off two more times. During this time also watch temp gauge and make sure it is staying about 11-12oclock.
will parking facing uphill work?
AdoboMiata is offline   Reply With Quote
Old 08-26-2012, 02:54 AM   #144
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

I bought a radiator cap from o'rileys and replaced the old one. The temperature stayed at "12:00" but would lean closer to hot after a somewhat long drive. I didn't remove the bubbles yet, I'll do that once the car cools down.
AdoboMiata is offline   Reply With Quote
Old 09-04-2012, 12:57 AM   #145
Newb
 
Join Date: Aug 2012
Posts: 15
Total Cats: 0
Default

how did you pull over and check the coolant level and not get your face burned off? did you just SLOWLY release pressure or what?

EDIT: nevermind i get it now
aznpersuasion89 is offline   Reply With Quote
Old 09-05-2012, 06:55 PM   #146
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by aznpersuasion89 View Post
how did you pull over and check the coolant level and not get your face burned off? did you just SLOWLY release pressure or what?

EDIT: nevermind i get it now
alrighht
AdoboMiata is offline   Reply With Quote
Old 11-20-2012, 01:29 AM   #147
Newb
 
Join Date: Jan 2011
Location: Indiana, PA
Posts: 10
Total Cats: 0
Default

i can't believe the lack of flaming on this thread.

any updates on the car?
jdem is offline   Reply With Quote
Old 11-20-2012, 11:49 PM   #148
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by jdem View Post
i can't believe the lack of flaming on this thread.

any updates on the car?

Yeah,
Attached Thumbnails
Installing Shanghai-S kit tomorrow..help?-374457_523875674289211_1502100247_n.jpg  
AdoboMiata is offline   Reply With Quote
Old 11-20-2012, 11:51 PM   #149
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

The problem I have now is getting the mspnp to run properly and to fix my coolant temp issue. I need to play with my VE table and AFR table so it doesn't lean out. I believe it's heatsoaking due to leaning out.
AdoboMiata is offline   Reply With Quote
Old 11-20-2012, 11:54 PM   #150
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,174
Total Cats: 2,575
Default

Quote:
Originally Posted by AdoboMiata View Post
T
I believe it's heatsoaking due to leaning out.
you are

beyond retarded
18psi is offline   Reply With Quote
Old 11-21-2012, 12:02 AM   #151
Junior Member
iTrader: (2)
 
Join Date: May 2011
Location: AL
Posts: 233
Total Cats: 10
Default

How are you not done with this car yet?
mellowout is offline   Reply With Quote
Old 11-21-2012, 02:34 PM   #152
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by mellowout View Post
How are you not done with this car yet?
Taking my time to learn more things about the mspnp

Quote:
Originally Posted by 18psi View Post
you are

beyond retarded

.. I changed the rad, thermostat, upper and lower hoses, and bled the system. My coolant-air density settings are off.. I didn't bother to tweak on that yet.
AdoboMiata is offline   Reply With Quote
Old 11-21-2012, 02:46 PM   #153
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

...shouldnt take 3 months to install a turbo kit and get the car running on a stand alone. Average time it takes 2 days to install a turbo kit, maybe 3 with an intercooler and a week to tune it with the first day getting most of the map tuned and the rest dealing with cold start and idle stuff.
triple88a is offline   Reply With Quote
Old 11-21-2012, 03:13 PM   #154
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by triple88a View Post
...shouldnt take 3 months to install a turbo kit and get the car running on a stand alone. Average time it takes 2 days to install a turbo kit, maybe 3 with an intercooler and a week to tune it with the first day getting most of the map tuned and the rest dealing with cold start and idle stuff.
took 3 days to install the kit with intercooler and didn't bother to tune it yet. Car sat for a while ever since the "heatsoaking" problem. I ordered some rx7 460cc injectors. I'll try to do another datalog today and post it up on here.
AdoboMiata is offline   Reply With Quote
Old 11-21-2012, 03:47 PM   #155
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

The car isnt going to fix it self sitting there mate.
triple88a is offline   Reply With Quote
Old 11-21-2012, 03:48 PM   #156
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Will I be able to tune with the Begi FPR??
AdoboMiata is offline   Reply With Quote
Old 11-21-2012, 03:49 PM   #157
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

You have the ms.. tune that pull the junk fpr.

Disconnect the waste gate and tune on the stock injectors up to 100ish kpa. Stock injectors will give you plenty of fuel.
triple88a is offline   Reply With Quote
Old 11-21-2012, 03:52 PM   #158
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by triple88a View Post
You have the ms.. tune that pull the junk fpr.

Disconnect the waste gate and tune on the stock injectors up to 100ish kpa. Stock injectors will give you plenty of fuel.
I forgot to mention, I am still using the MAF.
AdoboMiata is offline   Reply With Quote
Old 11-21-2012, 03:53 PM   #159
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

And stock ecu... when you install the ms the maf will come off
triple88a is offline   Reply With Quote
Old 11-21-2012, 04:05 PM   #160
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2011
Posts: 380
Total Cats: -17
Default

Quote:
Originally Posted by triple88a View Post
And stock ecu... when you install the ms the maf will come off
This requires the IAT sensor. right?
AdoboMiata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Noob to Miataturbo from MA JxPhan Meet and Greet 3 10-02-2015 03:17 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Koni 1150 Coilover Kit drumman83 Suspension, Brakes, Drivetrain 2 09-25-2015 08:03 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:03 PM.