DIYPNP install: inital tuning - Page 15 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 06-22-2011, 09:09 AM   #281
Junior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Working with my new best friend gVE to smoothen out the VE table works wonders!

Name:  622ve3smoothed.png
Views: 3
Size:  172.0 KB
Greg G is offline   Reply With Quote
Old 06-23-2011, 01:12 AM   #282
Junior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Just to relate all these graphs to reality, I uploaded a video. This is still with 3.1.1 mariob v5 code (D term not yet corrected). Spark and table switching with AC switch, and the AC compressor is on a time delay relay (here shortened a bit from the graphs posted). It's relatively stable with AC, but has some issues with headlights & AC on at the same time. I need to smoothen the VE table in that area.



Lots of noise in the background. There really is a vacuum cleaner running in the background, it's not my supercharger
Greg G is offline   Reply With Quote
Old 06-23-2011, 08:36 AM   #283
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,848
Total Cats: 1,788
Default

if I turn my lights and a/c on at the same time my radio turns off from the voltage drop.
Braineack is online now   Reply With Quote
Old 06-24-2011, 12:27 PM   #284
Junior Member
 
Join Date: May 2007
Location: Columbia, MD
Posts: 248
Total Cats: 0
Default

Does anyone else here with an ms2 want to try the D term changes I made? Seems Greg won't be able to for a while due to weather issues.

Ken
muythaibxr is offline   Reply With Quote
Old 06-24-2011, 12:55 PM   #285
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

What should we expect? I have fixed this in my own firmware, and with a D term of about 20 I didn't notice anything for the better or the worse.
Reverant is offline   Reply With Quote
Old 06-24-2011, 01:04 PM   #286
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

I had the best results with zero D term. I'll try it when I get back into town.
miatauser884 is offline   Reply With Quote
Old 06-24-2011, 02:33 PM   #287
Newb
 
Join Date: Feb 2011
Location: Oxford UK
Posts: 39
Total Cats: 0
Default

I'll try it out. My idle control on 3.1.1 sucks currently
PeteNMA is offline   Reply With Quote
Old 06-25-2011, 05:17 AM   #288
Junior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Car didn't start with the test code. Will wait for a new one.

In the meantime, I continued smoothing out the VE tables looking at gVE, and got the lights + AC to idle fairly well!



I was curious if I could get away with no tableswitching. Here's how it is with spark & table switching off:



It's actually not too bad. The dips are bigger- the instant spark bump from table switching must help out there. But perhaps putting a small slope in the spark table towards lower RPM (my spark tables are flat because I'm using table switching), plus the corrected D term in the next version will be enough to minimize the dip.

All 3 videos: P 25, I 12, D100

Last edited by Greg G; 06-25-2011 at 05:38 AM.
Greg G is offline   Reply With Quote
Old 06-28-2011, 03:27 AM   #289
Junior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Mariob v14, P 25i10d60. Looks bumpy, but note the scale. It's actually pretty smooth. Initial dip still not dead, but tolerable.

Name:  628p25i10d60.png
Views: 4
Size:  103.7 KB

Last edited by Greg G; 06-28-2011 at 04:29 AM.
Greg G is offline   Reply With Quote
Old 06-28-2011, 11:42 AM   #290
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Idle duty seems to hardly need to change?
And any D seems to be a bit weak. Did you try turning it up from 60?
How much did MarioB make D stronger? 2x? 4x?
JasonC SBB is offline   Reply With Quote
Old 06-28-2011, 12:06 PM   #291
Junior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

I believe mario just fixed the sign, didn't amplify the effect. Will edit the ini to allow crazy D again, and see what happens
Greg G is offline   Reply With Quote
Old 07-04-2011, 12:19 PM   #292
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Any luck? I have a couple of days that I can test new firmware if someone wants to send me the file. AND instructions on how to upload it if it hasn't been prepackaged. I can swap s19 files and direct tunerstudio to the new ini file necessary.
miatauser884 is offline   Reply With Quote
Old 07-04-2011, 12:32 PM   #293
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Quote:
Originally Posted by Greg G View Post
I believe mario just fixed the sign, didn't amplify the effect. Will edit the ini to allow crazy D again, and see what happens
Are you still running Mario_v5 or did you finally move to v14? If you are having good results with the v14 version, can you upload the microsquirt s19 file you are using?
miatauser884 is offline   Reply With Quote
Old 07-04-2011, 02:54 PM   #294
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

V14 works well for me.

Why do you want gregs .s19 file? Just grab the V14 zip from MSExtra.com and your away!
richyvrlimited is offline   Reply With Quote
Old 07-04-2011, 04:06 PM   #295
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Quote:
Originally Posted by richyvrlimited View Post
V14 works well for me.

Why do you want gregs .s19 file? Just grab the V14 zip from MSExtra.com and your away!
The latest v14 upload doesn't have a microsquirt s19 file.
miatauser884 is offline   Reply With Quote
Old 07-04-2011, 06:06 PM   #296
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

I thought the uS and MSII .s19's were merged now?
richyvrlimited is offline   Reply With Quote
Old 07-04-2011, 07:21 PM   #297
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

Quote:
Originally Posted by richyvrlimited View Post
I thought the uS and MSII .s19's were merged now?
Can someone please confirm? I guess worst case it wouldn't burn to my ecu if it wasn't merged.
miatauser884 is offline   Reply With Quote
Old 07-04-2011, 10:37 PM   #298
Junior Member
Thread Starter
 
Join Date: Jun 2007
Posts: 411
Total Cats: 0
Default

Haven't had any garage time to fool around with the car this week :P

Arrrg. s19 is not a valid file type for uploading (!) Could we get that fixed?

Anyway I posted it in MSExtra:
http://www.msextra.com/forums/viewto...289497#p289497

Have fun!

Greg
Greg G is offline   Reply With Quote
Old 07-05-2011, 12:36 AM   #299
Elite Member
iTrader: (11)
 
Join Date: Feb 2009
Posts: 2,982
Total Cats: 10
Default

I really appreciate all of the extra work for MS2, especially since I can't upgrade the diypnp to an MS3. I'd be more than willing to test new releases.
miatauser884 is offline   Reply With Quote
Old 07-05-2011, 03:25 AM   #300
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Quote:
Originally Posted by richyvrlimited View Post
I thought the uS and MSII .s19's were merged now?
No no no and you'll get all sorts of weird problems if you use the wrong .s19. The INIs have been merged, not the .s19.
Reverant is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:16 AM.