Radiator fan always on - driver side - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-03-2015, 12:34 AM   #41
Junior Member
Thread Starter
 
Join Date: Feb 2015
Posts: 103
Total Cats: 5
Default

Quote:
Originally Posted by 90 Turbo View Post
I am glad you got it fixed Gregor
Gregor, did you get it working?
Windows95 is offline   Reply With Quote
Old 12-03-2015, 09:52 AM   #42
Junior Member
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

Quote:
Originally Posted by Windows95 View Post
Gregor, did you get it working?
I haven't had s chance to test it yet. I've been getting long hours at work lately, but I'm off tomorrow. I'll stay up late and test tonight and post results.

I'm also adding sequential injection at the same time, hopefully I got that right.
Gregor is offline   Reply With Quote
Old 12-04-2015, 01:39 PM   #43
Junior Member
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

Well, the fans are no longer constantly on. But now the car won't start, I need to do some more research on sequential injection.
Gregor is offline   Reply With Quote
Old 12-04-2015, 01:46 PM   #44
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default

lol. :P
Braineack is offline   Reply With Quote
Old 12-04-2015, 07:57 PM   #45
Junior Member
Thread Starter
 
Join Date: Feb 2015
Posts: 103
Total Cats: 5
Default

Quote:
Originally Posted by Gregor View Post
Well, the fans are no longer constantly on. But now the car won't start, I need to do some more research on sequential injection.
Hmm...maybe I'll just deal with my fan problem for now. I also have sequential injection and it seems to be working. I used these instructions if that helps.
Windows95 is offline   Reply With Quote
Old 12-04-2015, 08:38 PM   #46
Junior Member
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

Thanks for the link, that was one of my several bookmarks. I just came back from a test drive. The fans no only come on when the right conditions are met(Thanks Braineack).

Now, I need to figure out why it won't idle after I park it and start it up warm.
Gregor is offline   Reply With Quote
Old 12-04-2015, 11:19 PM   #47
Senior Member
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Did you get the firmware updated?
It did help my idle to update it. All the buttons are in different places but there placement make more sense so it only takes a while to get used to.
90 Turbo is offline   Reply With Quote
Old 12-07-2015, 01:52 AM   #48
Junior Member
 
Join Date: Jun 2008
Location: Delhi CA
Posts: 91
Total Cats: 0
Default

I will give that a shot when I get back home. I thought it may be a heat soak issue with the IAT sensor. I will get more info as I start to drive the car again. It will be down for a short while since I just picked up a 6 speed tranny.
Gregor is offline   Reply With Quote
Old 01-13-2016, 11:53 AM   #49
Senior Member
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

I wanted to update my fan issue for anyone searching. Not that I 100% figured it out but it is the ac system. I basically removed the ac relay wire that turns the fan on when ac is on.
With my 1990 that's the black with green strip wire at relay by drivers head light. I used a little flat screw driver to remove the pin. So once I figure out Ac issue goes right back.
Once ac was not telling fan to turn on ms diypnp does it no problem.

Now to find out wtf is going on with ac but it's winter I have time. Lol
90 Turbo is offline   Reply With Quote
Old 01-13-2016, 12:17 PM   #50
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default

a/c relay activates the a/c compressor, a/c fan, and main cooling fan relay.
Braineack is offline   Reply With Quote
Old 01-13-2016, 03:25 PM   #51
Senior Member
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Quote:
Originally Posted by Braineack View Post
a/c relay activates the a/c compressor, a/c fan, and main cooling fan relay.
Thanks your correct.
My compressor clutch is not kicking on while I was trying to figure this out. It also does and did not turn on via button in dash. Might be broken.

Second fan was never reinstalled after mishimoto radiator.

I am going to try a new ac relay but I believe by removing only black green wire from ac relay I removed the wire that the relay uses to tell the fan relay to kick on. In my mind even if I never reconnect it ms will turn fan on at 185 whether ac is on or not. Might loss some ac cooling with less constant air flow over condensor?
90 Turbo is offline   Reply With Quote
Old 03-01-2016, 09:37 PM   #52
Junior Member
Thread Starter
 
Join Date: Feb 2015
Posts: 103
Total Cats: 5
Default

Before I start messing with anything on my car I wanted to post a shot of the soldering on my DIYPNP2 on my 95 to see if it might be a hardware issue.




Brain, and anyone else who knows what to look for, do you see anything obviously wrong? I finally have a turbo kit to install and I want to sort this out first!
Attached Thumbnails
Radiator fan always on - driver side-80-ms_mar2016_57255d455a4534b0d981ff30609d5fc897521da2.jpg  
Windows95 is offline   Reply With Quote
Old 03-03-2016, 09:13 PM   #53
Junior Member
Thread Starter
 
Join Date: Feb 2015
Posts: 103
Total Cats: 5
Default

I can take some photos from another angle if that would help...I'd like to resolve this fan thing and it doesn't seem to be a software issue.
Windows95 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
It runs! But not well.. Input appreciated. viriiguy MEGAsquirt 10 09-04-2015 07:28 PM
Using additional inputs on DIYPNP ChrisSTR MEGAsquirt 13 09-12-2014 08:08 PM
Trigger Input Wiring on Coil Pack Connector (x-posted) pluperfect_arson General Miata Chat 1 03-17-2014 10:40 AM
Has anyone used knock sensor input to switch ignition maps in FIC/6 on a Miata (2000) fwman1 AEM 4 01-28-2012 09:52 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:35 AM.