Second optoisolator on MS2 - Page 4 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-08-2013, 05:42 PM   #61
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

Ok false alarm. It seems that my crank pulley has slipped on its rubber isolator, Time for a new one I guess.
duffbuster243 is offline   Reply With Quote
Old 04-09-2013, 09:46 AM   #62
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

time for a 1.8L!
Braineack is online now   Reply With Quote
Old 04-09-2013, 10:32 AM   #63
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

The 1.6 Is built with b6t connecting rods and 9.0:1 compression pistons. I don't plan on going 1.8 any time soon.
duffbuster243 is offline   Reply With Quote
Old 04-13-2013, 08:58 PM   #64
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

I'm upgrading a MS2 to MS3, decided to add the second opto just as a precaution, although this has been running fine on ms2 since 2008 with just the pull-up on js10.





Attached Thumbnails
Second optoisolator on MS2-dsc_6194.jpg   Second optoisolator on MS2-dsc_6195.jpg   Second optoisolator on MS2-dsc_6196.jpg  

Last edited by Braineack; 04-14-2013 at 12:12 PM.
Braineack is online now   Reply With Quote
Old 04-14-2013, 12:12 PM   #65
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

I made a slight error when I built the circuit. I used the wrong hole for r49 so I was sending 5v to ground. I'll post new pics in a sec.

here's what I did:




syncs perfectly.
Attached Thumbnails
Second optoisolator on MS2-dsc_6201.jpg  

Last edited by Braineack; 04-14-2013 at 12:34 PM.
Braineack is online now   Reply With Quote
Old 04-14-2013, 06:31 PM   #66
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

Here's how I'm doing mine. FWIW


Last edited by WestfieldMX5; 04-28-2013 at 03:10 PM.
WestfieldMX5 is offline   Reply With Quote
Old 04-15-2013, 07:17 AM   #67
Junior Member
iTrader: (2)
 
Join Date: Dec 2009
Location: scranton, pa
Posts: 103
Total Cats: 4
Default

thanks for putting some leg work for our Ms2's duff! cant wait to drive without that sync loss we have seen.
zipstrips is offline   Reply With Quote
Old 04-15-2013, 09:05 AM   #68
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

Quote:
Originally Posted by WestfieldMX5 View Post
Here's how I'm doing mine. FWIW
It was because of you I tried doing it into a preexisting circuit, otherwise I'd have just done it on the proto.

I probably spent a good 2 minutes coming up with it and going gung-ho, I probably could have put more thought into it and made it cleaner, but i just didn't really care that much

Last edited by Braineack; 04-15-2013 at 05:38 PM.
Braineack is online now   Reply With Quote
Old 04-15-2013, 05:35 PM   #69
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

I probably have to much free time
WestfieldMX5 is offline   Reply With Quote
Old 04-15-2013, 05:53 PM   #70
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Sep 2010
Location: Scranton PA
Posts: 266
Total Cats: 4
Default

I used one of these: Dual General-Purpose IC PC Board : PC Boards | RadioShack.com cut in half, and bolted it on to the bottom of the MS board using a previously unused hole in the heatsink.
duffbuster243 is offline   Reply With Quote
Old 04-16-2013, 03:24 PM   #71
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Westfield, what are you trying to do with U7A? The majority of comparators' valid input range is VCC-1.5V. You are connecting its inverting input to VCC.
JasonC SBB is offline   Reply With Quote
Old 04-16-2013, 03:50 PM   #72
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

mirroring the circuit above, for the ckp, using the same 4n25 as seen on u3 in the U7A spot.

Attached Thumbnails
Second optoisolator on MS2-2ndcas_input.gif  
Braineack is online now   Reply With Quote
Old 04-16-2013, 06:54 PM   #73
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

Like he said
Same as Scott's, but in my drawing U3 goes in the lower 6 holes of the U7 location. Scott is using the upper holes.
WestfieldMX5 is offline   Reply With Quote
Old 04-17-2013, 01:22 AM   #74
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,914
Default

Quote:
Originally Posted by WestfieldMX5 View Post
Scott is using the upper holes.
I know for a fact that Scott prefers the lower hole.
Joe Perez is offline   Reply With Quote
Old 04-17-2013, 02:28 AM   #75
Senior Member
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

Quote:
Originally Posted by Joe Perez View Post
I know for a fact that Scott prefers the lower hole.
Dammit, now I spilled all the Coffee into my keyboard...
Zaphod is offline   Reply With Quote
Old 04-17-2013, 03:05 AM   #76
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Are you using a comparator symbol to denote an opto?
JasonC SBB is offline   Reply With Quote
Old 04-17-2013, 09:55 AM   #77
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

Quote:
Originally Posted by JasonC SBB View Post
Are you using a comparator symbol to denote an opto?
no? but I drove the car to work today.

Braineack is online now   Reply With Quote
Old 04-07-2015, 04:49 PM   #78
Newb
 
Join Date: Jun 2014
Posts: 18
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
mirroring the circuit above, for the ckp, using the same 4n25 as seen on u3 in the U7A spot.

Reviving the dead. Im running into issues with cam signal disappearing while cold crank or driving at low rpm randomly. Seems like either I can do this for cheap or try a new cam sensor. The choice look pretty obvious.

The problem is I am running DIYPNP V1.53B board, so these pins don't apply to me. I couldn't find the schematic for the V1.53B board so its pretty hard to see what is going on. I read somewhere the cam signal is fed directly to the CPU with only pull a 5 volt pullup.

So, I am going to build this on the proto area completely. From what I read so far, I should be able to use this circuit and feed it into the VR2+ the cam input without the pullup to 5V attached to VR2+.

For your convenience. Here is the pin out for DIYPNP board for 95 miata which is what Im driving.
DIYPNP MegaSquirt installation for the Mazda Miata
Zhimin90 is offline   Reply With Quote
Old 04-07-2015, 07:15 PM   #79
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

youre having drop out on a DIYPNP?

post the composite log to prove it.

how did you do you pull ups?
Braineack is online now   Reply With Quote
Old 04-07-2015, 09:03 PM   #80
Newb
 
Join Date: Jun 2014
Posts: 18
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
youre having drop out on a DIYPNP?

post the composite log to prove it.

how did you do you pull ups?
08.csv has dropout at 149/157
15.csv is at 112/153 and 58/153

I did the pull up according to the DIY PNP websites table for 94/95(VR2 to 470 resister pulled to 5v with R20 and r21 r39 open.
Attached Files
File Type: csv 2015-04-04_15.02.08.csv (1.73 MB, 37 views)
File Type: csv 2015-04-04_17.32.15.csv (1.68 MB, 40 views)
Zhimin90 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
mslabs MS2 - Idle control issue ndragun MEGAsquirt 0 09-20-2015 11:28 PM
ms2 pcb3 talkdown/checklist labrat MEGAsquirt 2 08-03-2009 10:21 PM
Need some info and guidence on setting up a MS2 for a 2000 NB JRSC car. stubbs MEGAsquirt 14 02-13-2009 12:32 PM
Fs: Ms2 Cpu. neogenesis2004 Miata parts for sale/trade 1 10-26-2007 11:43 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:42 AM.