Astroboy's reliability build (pic intensive) - Page 6 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-22-2011, 12:32 AM   #101
Junior Member
iTrader: (3)
 
Join Date: Oct 2010
Posts: 201
Total Cats: 2
Default

epic build
samwu8k is offline   Reply With Quote
Old 04-22-2011, 02:15 AM   #102
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Quote:
Originally Posted by charlie_91 View Post
such a sick bay.. where did u get ur cam gears ? every place ive emailed said there out of stock..
Thanks man! I got my gears second hand from two different people. The purple one is flyinmiata and the other is fidanza.

Quote:
Originally Posted by baron340 View Post
Build is looking great so far. One little detail though... you might want to reconsider using Super Blue brake fluid. It works well and the boiling point is pretty high, but it will stain every single thing it touches blue forever. We usually use Motul RBF 600 or 660 at work, nice high boiling point and doesn't stain every damn thing blue.

Other than that, it looks fabulous. I'm impressed with the whole brake reroute.
Didn't know that. Think I'll be reconsiddering the use of super blue, thanks for the advice. Also thanks for the kind words! My buddy helped me get the lines bent just rite.
astroboy is offline   Reply With Quote
Old 04-22-2011, 10:15 AM   #103
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

Purple! winning!
Faeflora is offline   Reply With Quote
Old 04-22-2011, 09:54 PM   #104
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Quote:
Originally Posted by samwu8k View Post
epic build
Thanks, but I don't think my build is on the level that is needed for the E word.

Quote:
Originally Posted by Faeflora View Post
Purple! winning!
I don't think I am going to keep the purple. That's a junk turbo that I fooled around with the idea of matching the turbo and intake manifold to the cam gears. I don't think I am pulling it off well so for now I am going to coat the turbo (the unmolested t3/t04b) with some silver ****, clean the compressor housing, and run it with the cam gear cover on.


Nobody has input on the amphenol placement? That makes me sad:(
astroboy is offline   Reply With Quote
Old 04-22-2011, 10:43 PM   #105
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

Huh? What turbo is that if it's not the 50 trim?
Faeflora is offline   Reply With Quote
Old 04-22-2011, 10:46 PM   #106
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

Ask Sean about the amphenol placement.

If it were me though I would slam that shiz either

close to where most of the wires will go
and/or
out of sight-ish
Faeflora is offline   Reply With Quote
Old 04-23-2011, 07:41 AM   #107
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Quote:
Originally Posted by Faeflora View Post
Huh? What turbo is that if it's not the 50 trim?
It is a junk super 60 I bought

Quote:
Originally Posted by Faeflora View Post
If it were me though I would slam that shiz either close to where most of the wires will go and/or out of sight-ish
That is the plan rite now. I was looking for an argument that would convince me to put it elsewhere but haven't gotten much "don't do that because bla" yet.
astroboy is offline   Reply With Quote
Old 04-28-2011, 11:07 PM   #108
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Punched a hole in the firewall for the amphenol, loomed the wires to where they need to go and started finishing the looms in the cabin. I want to make sure I have it allfigured out before I wire the amphenol up. I decided to not wire the O2 and the EGT probe in because they may (and most likely will) go bad so rather than have to splice new sensors in I am going to go the rubber doughnut route for those two. I also pulled out the alarm and fixed the hacked up random **** wired into the ignition. Looks better now and most likely won't catch fire

Amphenol placement


New FPR's


Fixed ignition wires


Sweet wheel placement!
astroboy is offline   Reply With Quote
Old 04-29-2011, 01:26 AM   #109
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,109
Total Cats: 518
Default

Nice MS placement, about a foot forward from mine. Only issue is I can't see when my warm up enrichments are off when datalogging, it blocks the LEDs.
curly is offline   Reply With Quote
Old 04-29-2011, 01:48 AM   #110
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

What brand fuel pressure gauge is that? you have the same regulator as me does
Faeflora is offline   Reply With Quote
Old 04-29-2011, 07:37 AM   #111
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Quote:
Originally Posted by curly View Post
Nice MS placement, about a foot forward from mine. Only issue is I can't see when my warm up enrichments are off when datalogging, it blocks the LEDs.
Thanks, I have been thinking of relocating it a little farther away from the passenger but it being there makes it way easy to see those leds.

Quote:
Originally Posted by Faeflora View Post
What brand fuel pressure gauge is that? you have the same regulator as me does
One is an ebay one and the other is an aeromotive 13105.
astroboy is offline   Reply With Quote
Old 04-29-2011, 10:06 AM   #112
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

? What two FPRs?
Faeflora is offline   Reply With Quote
Old 04-29-2011, 10:38 AM   #113
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Quote:
Originally Posted by Faeflora View Post
? What two FPRs?
The ebay one is leaning to the right on the left (with the pressure gauge on it), the aeromotive is on the right leaning to the left.
astroboy is offline   Reply With Quote
Old 04-29-2011, 01:12 PM   #114
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default



Er I meant WHY two fprs :(
Faeflora is offline   Reply With Quote
Old 04-29-2011, 02:58 PM   #115
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Oh, well I got the ebay one and the aeromotive one came up for a good price a few days later.
astroboy is offline   Reply With Quote
Old 04-29-2011, 03:01 PM   #116
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

is it crazy that I looked at your MS and thought I remember that one?
Braineack is offline   Reply With Quote
Old 04-29-2011, 03:05 PM   #117
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Quote:
Originally Posted by Braineack View Post
is it crazy that I looked at your MS and thought I remember that one?
Neah, you probably remember it because of the usb thing. How many people get those? I ended up just going with a serial to usb cable.
astroboy is offline   Reply With Quote
Old 04-29-2011, 03:08 PM   #118
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

thats probably the only I built with it.
Braineack is offline   Reply With Quote
Old 05-18-2011, 01:58 PM   #119
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Finally found time to get **** done. Here is my list o' completed things:
-fuel rail modified so it will actually work with the 99 head and installed
-fuel lines run
-fpr modified and mounted
-valve cover modified and mounted
-iat sensor relocated to the front of the intercooler
-old iat bung plugged
-sheared bolt pulled out of the turbine housing
-cut the support bracket mount off the intake manifold
-scrubbed the intake manifold down

Some less than adequate pics...sorry guys :(







Up next I am going to por15 all the rusty ****, make the throttle cable work with the 99 junk, sandblast the turbine housing, and paint that beeoch.
astroboy is offline   Reply With Quote
Old 05-20-2011, 09:19 AM   #120
Elite Member
Thread Starter
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

Last night I:
removed purple turbo
cleaned the t3/t04b turbine and compressor housings
painted the turbine housing with vht primer and silver
clocked the chra and put the turbo together
mounted that bitch to see how it jived with the rest of the engine
hooked up the oil feed
mocked up the coolant lines
pulled the fuel pump (which had me dremeling the screw because that ****** didn't want to come out)

Here is a shot of it as of this morning:


astroboy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:12 AM.