New to the forum. - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Meet and Greet Say Hi. De-noob yourself.

Reply
 
 
 
LinkBack Thread Tools
Old 12-04-2015, 06:33 PM   #21
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Quote:
Originally Posted by rleete View Post
I swear to god I'm going to find a mint NB and swap in a 1.6 just to **** you people off.
I love this. When I swap my motor ill give you mine just so you can do this. Hilarious
Hificruzer226 is offline   Reply With Quote
Old 12-04-2015, 11:42 PM   #22
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Update:
Found no leaks in piping.
Eliminated bov


Still no boost condition Grrrrrrrrr

I am thinking my vacuum lines are screwed up somewhere. Tomorrow I am going to varify throttle is opening correctly and internal wg is staying completely shut.

I am just about lost after that. No smoke, I can hear spool tHan it flat ines, car idles fine, runs fine gets a tiny bit above 0lbs of boost instantly.
Hificruzer226 is offline   Reply With Quote
Old 12-04-2015, 11:55 PM   #23
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

How are you checking boost. How do you know your boost gauge line isn't kinked?
aidandj is offline   Reply With Quote
Old 12-05-2015, 12:02 AM   #24
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Quote:
Originally Posted by aidandj View Post
How are you checking boost. How do you know your boost gauge line isn't kinked?
Haven't checked that however I can at least say under bonnet it's free and clear.
Hificruzer226 is offline   Reply With Quote
Old 12-05-2015, 12:05 AM   #25
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

It just doesn't feel like a turbo car I don't feel any boost build. The gauge reacts to rpm and throttle position respectively.
Hificruzer226 is offline   Reply With Quote
Old 12-05-2015, 09:36 AM   #26
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,851
Total Cats: 271
Default

Do you have a way of connecting pressurized air to a hose and connect it to your wastegate? Up the PSI till you see the WG crack open, if it's opening right away then a new one is in order
Girz0r is offline   Reply With Quote
Old 12-05-2015, 09:41 AM   #27
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Quote:
Originally Posted by Girz0r View Post
Do you have a way of connecting pressurized air to a hose and connect it to your wastegate? Up the PSI till you see the WG crack open, if it's opening right away then a new one is in order
Thats a good idea. I am gonna adjust the WG.
Hificruzer226 is offline   Reply With Quote
Old 12-05-2015, 09:59 AM   #28
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,199
Total Cats: 260
Default

and

May be slightly difficult to see with the way the turbo is clocked. But you get the idea.
Also check and verify timing(not just by the timing mark on the crank. Make sure that is correct.
Erat is offline   Reply With Quote
Old 12-05-2015, 01:10 PM   #29
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

[QUOTE=Erat;1289416]
May be slightly difficult to see with the way the turbo is clocked. But you get the idea.
Also check and verify timing(not just by the timing mark on the crank. Make sure that is correct.

Thanks Ill give it a shot.
I found out my pcv valve no showed, I was hoping it would because I feel as though pcv would be a good culprit for this scenario. :(
Hificruzer226 is offline   Reply With Quote
Old 12-05-2015, 01:22 PM   #30
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,851
Total Cats: 271
Default

the upgraded pcv valve is still a good safety measure Mine seemed to help with oil consumption.

What kind of bov is that?
Girz0r is offline   Reply With Quote
Old 12-05-2015, 02:22 PM   #31
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Quote:
Originally Posted by Girz0r View Post

What kind of bov is that?
Still gonna put it on I was hoping to have it today for install tomorrow but mr postman no deliver :*(

Its looks like some ebay garbage or as you guys say AIDS. At the moment it is not on the car nor is the intercooler. I did that to eliminate boost leak possibility. But problem still persists. So I am think WG which I will check tonight, vacuum line issue or pcv other than that I am in over my head... oh wait
Hificruzer226 is offline   Reply With Quote
Old 12-05-2015, 10:14 PM   #32
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,673
Total Cats: 1,561
Default

You will need to protect the brake master cylinder and reservoir from the turbo and exhaust system heat. Things melt and boil.
sixshooter is online now   Reply With Quote
Old 12-06-2015, 08:49 AM   #33
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,851
Total Cats: 271
Default

I feel that this thread needs moar photos.

Don't forget to grab a spectre breather filter.
Girz0r is offline   Reply With Quote
Old 12-06-2015, 06:12 PM   #34
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Quote:
Originally Posted by Girz0r View Post
I feel that this thread needs moar photos.

Don't forget to grab a spectre breather filter.
OK here is some along with questions

I didn't know Megan racing had a turbo manifold for the 1.6
Attached Thumbnails
New to the forum.-80-1449439843167_1609246781_4f1d0cc91343a0f5e7ee287cf04e4d752a43d2c0.jpg  
Hificruzer226 is offline   Reply With Quote
Old 12-06-2015, 06:16 PM   #35
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

It's ****. Like all of Megan's stuff.
aidandj is offline   Reply With Quote
Old 12-06-2015, 06:17 PM   #36
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Quote:
Originally Posted by aidandj View Post
It's ****. Like all of Megan's stuff.
Lol
Hificruzer226 is offline   Reply With Quote
Old 12-06-2015, 06:19 PM   #37
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

Still no boost I've adjusted the actuator to its longest setting shortest and right in the middle . I tightened all clamps and still no boost. :(
Hificruzer226 is offline   Reply With Quote
Old 12-06-2015, 06:20 PM   #38
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

And not shitty in a "won't spool as well" way. **** in a "will break in a week" way.
aidandj is offline   Reply With Quote
Old 12-06-2015, 06:23 PM   #39
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

You exhaust manifold might have a giant hole in it.
aidandj is offline   Reply With Quote
Old 12-06-2015, 07:30 PM   #40
Junior Member
Thread Starter
 
Join Date: Dec 2015
Posts: 203
Total Cats: -6
Default

I think I figured it out but I can't spend anymore time on it. Exhaust mani was not locker down tight and the turbo doesn't seem to be tightened down correctly.
I think this would Def be a culprit that would give me the exact symptoms I have had.

What other mani can I use one this motor with my turbo. I am familiar with Meagan being a half step from generic ebay parts.
Hificruzer226 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Car is so loud on inside. Helmholtz branch (1/4 wave) resonator? psyber_0ptix Engine Performance 34 12-10-2016 09:51 PM
New to Miatas, new to cars. dickamusmaxamus Meet and Greet 35 07-29-2016 02:50 PM
Turbo ND? Cool car Corky Bell Prefabbed Turbo Kits 23 02-11-2016 02:42 PM
Main relay - Car won't start .one lane General Miata Chat 6 11-10-2015 12:46 PM
Yonaka NB coilovers in NA car Zeddriver Suspension, Brakes, Drivetrain 4 11-07-2015 02:15 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:59 PM.