Enhanced Megasquirt Group Buy for all Miatas (90-05) - Page 22 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 03-29-2012, 03:29 AM   #421
Supporting Vendor
Thread Starter
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Tracking link emailed.
Reverant is offline   Reply With Quote
Old 03-31-2012, 07:18 PM   #422
Newb
 
Join Date: Jun 2010
Location: Minneapolis, MN
Posts: 40
Total Cats: 0
Default OEM mounting location details

Quote:
Originally Posted by MoonieGT View Post
Regarding mounting in a '99: you MIGHT be able to mount in the stock location, but it will TIGHT.
I mounted mine in the OEM location pretty easily. I'd show a couple pictures but I'm too lazy to figure out an image host service.

I reused the lower bracket. It attaches to the MS case using small bolts/nuts/washers. A zip tie between the front of the case and the upper bracket stabilizes it.

****IF you do this, you need to buy a 90 degree, serial adapter for your communication cable. There isn't enough room to attach a serial cable using the OEM lower bracket because the MS sits too close to the firewall. Another option may be to cut out part of the firewall insulation but that didn't occur to me until just now.

I can't remember where I ordered the adapter but it required slight modification (dremel tool) to screw it to the MS because the mounting screws weren't long enough. I could have bought longer screws but it was easier to cut the plastic than drive to find longer, tiny bolts with proper thread pitch! I didn't take any pictures of the modified adapter. My serial cable screws into the adapter and exits towards the driver's front tire. I ran the cable under the dash, down the console, and up into the storage compartment through the hole for the truck/gas release levers.

I considered posting a "How To Mount" post but figured if you can't figure out how to mount it sercurely, maybe you shouldn't be installing it.
Jesse99James is offline   Reply With Quote
Old 04-03-2012, 09:59 AM   #423
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Quote:
Originally Posted by Jesse99James View Post
I mounted mine in the OEM location pretty easily. I'd show a couple pictures but I'm too lazy to figure out an image host service.
Shoot me a pm with your email address and we will see if we can get the pictures up and hosted.
shuiend is offline   Reply With Quote
Old 04-03-2012, 10:11 AM   #424
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I'm mounting my computer into my ***.
hustler is offline   Reply With Quote
Old 04-03-2012, 12:16 PM   #425
Supporting Vendor
Thread Starter
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Quote:
Originally Posted by hustler View Post
I'm mounting my computer into my ***.
That will definitely void your warranty.
Reverant is offline   Reply With Quote
Old 04-03-2012, 02:22 PM   #426
Junior Member
iTrader: (5)
 
Join Date: Oct 2011
Location: San Diego, CA
Posts: 402
Total Cats: 21
Default

Quote:
Originally Posted by Reverant View Post
That will definitely void your warranty.
Haha! Yeah, I wouldn't want to be the one to RMA that ----!
slmhofy is offline   Reply With Quote
Old 04-03-2012, 02:43 PM   #427
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Reverant View Post
That will definitely void your warranty.
I guess he's not into "Greek".

zing.
hustler is offline   Reply With Quote
Old 04-03-2012, 02:44 PM   #428
Supporting Vendor
Thread Starter
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Touche.
Reverant is offline   Reply With Quote
Old 04-04-2012, 02:12 AM   #429
Junior Member
iTrader: (3)
 
Join Date: Apr 2010
Location: San Antonio, TX
Posts: 411
Total Cats: 1
Default

It hasn't even been two weeks and I'm antsy to get this EMS.
RavynX is offline   Reply With Quote
Old 04-04-2012, 09:25 AM   #430
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Below are pictures and a brief write up that Jesse99James did.

I bought a DB9, 90 degree adapter. I used MS Paint to show how I modified it. The screws/bolts weren’t long enough to attach to the serial port on my MSII. Cutting the DB9 adapter was easier than locating longer screws. Beware, there are multiple (4?), 90 degree adapters. You do NOT want the two that have screws on the Female side. The two you want will have screws on the Male side. The only difference is the direction it points.

I chose to buy the one that points towards the driver’s side. Either may work BUT I can’t remember if there was a reason I chose this adapter. ...there may be an obstruction towards the passenger side.

I also used a zip tie to secure the front of the MS case to the upper bracket.



Attached Thumbnails
Enhanced Megasquirt Group Buy for all Miatas (90-05)-90serial.jpg   Enhanced Megasquirt Group Buy for all Miatas (90-05)-bracket2.jpg   Enhanced Megasquirt Group Buy for all Miatas (90-05)-bracket1.jpg  
shuiend is offline   Reply With Quote
Old 04-04-2012, 12:16 PM   #431
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Oh ----, I was thinking this was just like my MSpnp, what kind of cable do I need to plug into the MS2+++ computer?

My package arrived yesterday, there is a two-day window for me to pick it up, and I was told yesterday they will not give it to me because my delivery address differs from my license. This is ------- retarded. I'm going back to argue more today.
hustler is offline   Reply With Quote
Old 04-04-2012, 12:25 PM   #432
Supporting Vendor
Thread Starter
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Quote:
Originally Posted by hustler View Post
Oh ----, I was thinking this was just like my MSpnp, what kind of cable do I need to plug into the MS2+++ computer?
Either a serial port or a USB to serial port. If you have the gear to connect with the MSPNP, then you don't need anything else to connect to the Enhanced MS2.
Reverant is offline   Reply With Quote
Old 04-04-2012, 12:27 PM   #433
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Reverant View Post
Either a serial port or a USB to serial port. If you have the gear to connect with the MSPNP, then you don't need anything else to connect to the Enhanced MS2.
I need a longer cable, but that's it.
hustler is offline   Reply With Quote
Old 04-04-2012, 12:39 PM   #434
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

The pictures are only for mounting it in the stock location on an NB.
shuiend is offline   Reply With Quote
Old 04-04-2012, 12:54 PM   #435
Junior Member
iTrader: (3)
 
Join Date: Apr 2010
Location: San Antonio, TX
Posts: 411
Total Cats: 1
Default

Quote:
Originally Posted by shuiend View Post
The pictures are only for mounting it in the stock location on an NB.
Awesome, thanks. Do you have any photos of it mounted up?
RavynX is offline   Reply With Quote
Old 04-04-2012, 03:58 PM   #436
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,775
Total Cats: 1,106
Default

Quote:
Originally Posted by RavynX View Post
Awesome, thanks. Do you have any photos of it mounted up?
Need to ask JesseJames. I just posted the pictures for him.
shuiend is offline   Reply With Quote
Old 04-04-2012, 09:35 PM   #437
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Do I need to pull a fuse or anything crazy like that or just plug in and start doing burn-outs?
hustler is offline   Reply With Quote
Old 04-04-2012, 10:27 PM   #438
Newb
 
Join Date: Jun 2010
Location: Minneapolis, MN
Posts: 40
Total Cats: 0
Default

Quote:
Originally Posted by RavynX View Post
Awesome, thanks. Do you have any photos of it mounted up?
No pictures of it mounted. There is clearance all around. It doesn't touch anywhere other than the single, 10mm bolt to the firewall through the OEM bracket as shown mounted in the above pictures PLUS one plastic wire tie to the OEM, upper bracket. This just shows my solution after reading somebody say mounting the MSII in the OEM spot was tight. It really isn't that bad! It doesn't require making new brackets or modifying anything other than the 90* serial adaptor which was <$15 shipped IIRC. All the holes used are already in the MSII case. I simply cut down two bolts and dug out a few washers and nuts from my spare parts bins.

I don't have cruise control so I ran my wideband O2's signal wire and the vacuum hose through the hole in the firewall that was intended for the cruise control cable. YMMV for vacuum hose and other wiring.
Jesse99James is offline   Reply With Quote
Old 04-04-2012, 11:13 PM   #439
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

What wire are you guys using for the WB input?

I typically drill a big hole in the passenger side footwell for all the accessory wires, then foam it shut so it's somewhat water tight. If I ever get the dash out of the green car I'm doing a bulkhead there in its place.
hustler is offline   Reply With Quote
Old 04-05-2012, 01:02 PM   #440
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I ahve a few dumb questions that I'll open to the peanut gallery rather than email Dimitris over and over.

I'd like to use the factory o2 sensor harness if possible to run the WB signal, Gauge signal, and the other two wires for calibration. Can I use those wires for this? If so, is it a bitch to add a pin to the connector for the factory o2 signal wire?
hustler is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
starting issue Johnny Tater Engine Performance 3 09-23-2015 07:10 PM
Megasquirt 2 or 3 ? TheNomad Engine Performance 3 09-21-2015 11:20 PM
Miata Newbie hdizzle Meet and Greet 8 09-21-2015 11:08 AM
SOLD-Rear knuckle/spindle upper spherical bearing adapter hi_im_sean Miata parts for sale/trade 1 09-16-2015 01:45 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:58 AM.