RedTurbo's not red and not Turbo'd (yet) build - Page 7 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 06-19-2013, 06:09 PM   #121
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default


Attached Thumbnails
RedTurbo's not red and not Turbo'd (yet) build-null_zpsf6a9cca2.jpg   RedTurbo's not red and not Turbo'd (yet) build-null_zpse6797996.jpg  
redturbomiata is offline   Reply With Quote
Old 06-20-2013, 12:34 AM   #122
I take big bites
iTrader: (1)
 
turbofan's Avatar
 
Join Date: Sep 2010
Location: Hurricane, UT
Posts: 6,930
Total Cats: 526
Default

Looks awesome. Awesome awesome.
turbofan is offline   Reply With Quote
Old 06-21-2013, 12:34 AM   #123
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Worked most of today so didnt get much miata time, but did manage to get the steering rack back in, new timing belt on, turbo final mounted, wastegate on. i have to check and make sure the wastegate will work in that position it felt a bit weird. some wiring for oil temp/pressure gauges ran. only pic for the night.
Attached Thumbnails
RedTurbo's not red and not Turbo'd (yet) build-null_zps2353fd97.jpg  
redturbomiata is offline   Reply With Quote
Old 06-21-2013, 12:50 AM   #124
Senior Member
iTrader: (8)
 
Join Date: May 2011
Location: Granbury, Tx
Posts: 815
Total Cats: 14
Default

I regret selling my 93 and this setup. I miss boooost :(
FowlerMotorsports is offline   Reply With Quote
Old 06-21-2013, 01:21 AM   #125
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,206
Total Cats: 2,587
Default

So boost your car already then, fgt......lolol
School is for suckers
18psi is offline   Reply With Quote
Old 06-21-2013, 08:23 PM   #126
Senior Member
iTrader: (8)
 
Join Date: May 2011
Location: Granbury, Tx
Posts: 815
Total Cats: 14
Default

Quote:
Originally Posted by 18psi View Post
So boost your car already then, fgt......lolol
School is for suckers
Give me the stoopidcharger when you're done, i'll risk it til I am done with school lol

Tadd, think you'll have it running this weekend or is work cray?
FowlerMotorsports is offline   Reply With Quote
Old 06-21-2013, 11:43 PM   #127
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Quote:
Originally Posted by FowlerMotorsports View Post
Give me the stoopidcharger when you're done, i'll risk it til I am done with school lol

Tadd, think you'll have it running this weekend or is work cray?
im not 100% sure, it will probably end up being like 99% done by the end of the weekend. which is fine because i discovered one of my motor mounts is broken so i ordered some mazda comps from good win racing should be here next week. also i know i need a couple of intercooler t clamps and a reducer for the throtle body connection that i haven't had a chance to measure and order yet. but luckily for me Jegs and Summit Racing are close enough that i pay for standard shipping (usually Free) and it comes next day.

But its starting to look almost complete which is a good sign right. Erat is coming out tommorow and we are drilling and tapping the oil pan for the drain line, im going to try and get the fuel system done, and possibly start piecing together the intercooler piping.
Attached Thumbnails
RedTurbo's not red and not Turbo'd (yet) build-null_zps84f1b6b8.jpg  
redturbomiata is offline   Reply With Quote
Old 06-22-2013, 03:52 PM   #128
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Oil pan drilled and tapped, fitting installed and sealed, oil drained and flushed, and radiator installed for mock up of the intercooler. but its like 90 with 170+% humidity and my work light is a halogen so its hotter than **** in the garage so im done till i get off work tonight and maybe i will get some more done.
redturbomiata is offline   Reply With Quote
Old 06-24-2013, 11:35 PM   #129
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Started today trying to finish up the fuel system, why is it so hard to find a female 3/8 npt to 5/16 barb fitting? anyway did the fuel pump it had a walbro in it already, part number was different from my 255lph so possibly a 195. tank looked new and the tray had 0 rust on it, which was a huge bonus.
fit the fuel rail and injectors as well
redturbomiata is offline   Reply With Quote
Old 06-26-2013, 02:27 PM   #130
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

So I'm working on my car and the motor mounts were ripped so Im now installing some new ones. Before the motor was sorta level from side to side, now on the reinstall the motor is tilting heavily to the passenger side. What did I do wrong? It looks like all the marks from the previous set line up with where the new set sits.
redturbomiata is offline   Reply With Quote
Old 06-26-2013, 03:01 PM   #131
Senior Member
iTrader: (8)
 
Join Date: May 2011
Location: Granbury, Tx
Posts: 815
Total Cats: 14
Default

Did the motor mount fall into the wrong hole? I did that on accident
FowlerMotorsports is offline   Reply With Quote
Old 06-26-2013, 03:02 PM   #132
Elite Member
iTrader: (13)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,704
Total Cats: 237
Default

Quote:
Originally Posted by FowlerMotorsports View Post
Did the motor mount fall into the wrong hole? I did that on accident
I've "fallen into the wrong hole" on accident quite a few times as well.

Seriously though, the passangers side goes in first, the drivers side is notched and slides into place. Did you do it that way?
Fireindc is offline   Reply With Quote
Old 06-26-2013, 03:05 PM   #133
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Quote:
Originally Posted by FowlerMotorsports View Post
Did the motor mount fall into the wrong hole? I did that on accident
Quote:
Originally Posted by Fireindc View Post
I've "fallen into the wrong hole" on accident quite a few times as well.

Seriously though, the passangers side goes in first, the drivers side is notched and slides into place. Did you do it that way?
The driverside fell in first and then leans in hard to the passengerside. im thinking maybe the exhaust being bolted in is prohibiting some movement?
redturbomiata is offline   Reply With Quote
Old 06-26-2013, 03:21 PM   #134
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,206
Total Cats: 2,587
Default

Quote:
Originally Posted by Fireindc View Post
I've "fallen into the wrong hole" on accident quite a few times as well.
surprise
18psi is offline   Reply With Quote
Old 06-26-2013, 03:22 PM   #135
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Quote:
Originally Posted by 18psi View Post
surprise
i see what you did there
redturbomiata is offline   Reply With Quote
Old 06-26-2013, 04:34 PM   #136
Senior Member
iTrader: (8)
 
Join Date: May 2011
Location: Granbury, Tx
Posts: 815
Total Cats: 14
Default

Pull out an give it another shot.. giggity

Passanger side first, then drivers
FowlerMotorsports is offline   Reply With Quote
Old 06-26-2013, 08:39 PM   #137
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: May 2011
Location: London,OH
Posts: 1,125
Total Cats: 13
Default

Got it, the motor keep seating the motor mount stud in the wrong hole. Mounted driver side to the chassis and let the passenger settle where it may and fell right into place. Win
redturbomiata is offline   Reply With Quote
Old 06-26-2013, 08:47 PM   #138
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

Noted.

*Don't put it in the wrong hole*
Erat is offline   Reply With Quote
Old 06-26-2013, 09:16 PM   #139
Senior Member
iTrader: (8)
 
Join Date: May 2011
Location: Granbury, Tx
Posts: 815
Total Cats: 14
Default

Quote:
Originally Posted by Erat View Post
Noted.

*Don't put it in the wrong hole*
That's what she said
FowlerMotorsports is offline   Reply With Quote
Old 06-26-2013, 11:08 PM   #140
Newb
 
Join Date: Jun 2013
Posts: 34
Total Cats: 1
Default

nice build. anything good coming out of removing the timing belt covers?
awdracer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:55 PM.