Impuls build - Page 8 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 11-18-2013, 11:09 AM   #141
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by miata2fast View Post
The pic maybe deceiving, but it looks like your ride height is set too low. If your ride height is too high or low, you are much more likely to break axles.
It may be too low for drag. it doesn't help that clutch dumped around 5000rpm either. launch control didn't activate. Everyone in the stands thought it was cool haha
Attached Thumbnails
Impuls build-c360_2013-11-08-16-03-30-065-1_zps01dd9164.jpg  
Impuls is offline   Reply With Quote
Old 11-23-2013, 11:20 PM   #142
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

I finally got my EBC hooked up. I gotta go threw the settings of course. Though I'm finally back up at +15psi.
Am I the only one that has crazy MAT correction values?
Attached Thumbnails
Impuls build-matcorrection_zpsa2f0dc17.jpg  
Impuls is offline   Reply With Quote
Old 11-24-2013, 08:41 PM   #143
Elite Member
iTrader: (2)
 
miata2fast's Avatar
 
Join Date: Aug 2009
Location: Dover, FL
Posts: 2,897
Total Cats: 109
Default

Where is your bumper
miata2fast is offline   Reply With Quote
Old 11-24-2013, 08:50 PM   #144
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by miata2fast View Post
Where is your bumper
A trailer didn't like it.
Attached Thumbnails
Impuls build-c360_2012-11-02-14-38-27_zps5045fdf9.jpg  
Impuls is offline   Reply With Quote
Old 11-25-2013, 02:26 AM   #145
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

Quote:
Originally Posted by Impuls View Post
Am I the only one that has crazy MAT correction values?
[IMG]https://www.miataturbo.net/attachment.php?attachmentid=95507&dateline=1385263 225[IMG]
that doesn't look right. at all
I've never seen a car that requires more than a couple % between 60-80 or 80-100

*edit - though I'm on ms3 and I think you're on ms2 and I already forgot how ms2 is setup. can't see it being much different though
18psi is offline   Reply With Quote
Old 11-25-2013, 04:41 AM   #146
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by 18psi View Post
that doesn't look right. at all
I've never seen a car that requires more than a couple % between 60-80 or 80-100

*edit - though I'm on ms3 and I think you're on ms2 and I already forgot how ms2 is setup. can't see it being much different though

My AFR's go lean right after 80f thus why it skyrockets.
Which I remember reading Brain say something about MS doing that after 80F before but that was a while ago.

I would think the Ideal Gas Law doesn't just change for those who have MS2 from MS3, though it does make you moar awesome then me :(
Impuls is offline   Reply With Quote
Old 11-25-2013, 04:12 PM   #147
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,196
Total Cats: 2,583
Default

Ive just never seen it that drastic on any tune I've ever seen.

20% increase is seriously a crazy amount of fuel to need between two temp points. I don't think I've seen anyones whole correction curve swing that much for the whole spread.

I dunno, maybe I'm wrong. But I would look into that if I were you.
18psi is offline   Reply With Quote
Old 11-25-2013, 09:23 PM   #148
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Thank you, I appreciate the incite man. I'll contact DIY after they get back about my 2nd set if burnt components on a MS board. Or I'll try looking into the MAT correction/ fueling code.

Also when a fuel/VE map peaks at a certain point before redline (5000-5500rpm) then starts tapering of near redline. Does that mean the turbo runs out of the ability to feed the engine? Thus, too small? Or is it kinda normal with small engine/ huge injectors?
Impuls is offline   Reply With Quote
Old 11-26-2013, 08:49 PM   #149
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Impuls is offline   Reply With Quote
Old 11-29-2013, 11:15 PM   #150
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

I must be doing something wrong.

At about 23 seconds you can see spark escaping my ignition wire.
Shitty MSM ignition & turbo? Not to mention running pressure well over what it's meant to run.
My AFR (yes shitty Prosport) says I'm in the 12-11.8 range. The dyno's AFR says I go pig rich at ~3900rpm

Ignore the file's title. haha
Attached Thumbnails
Impuls build-c360_2013-11-27-18-40-25-520_zps9c887ee6.jpg   Impuls build-c360_2013-11-27-18-40-25-520_zps9c887ee6.jpg  
Impuls is offline   Reply With Quote
Old 12-03-2013, 10:09 PM   #151
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Doing all my wheel bearings:
Front hubs are from Planetmiata.
Rear bearings are from parts store I know work for. Going to have them pressed in.

Also looking to replace/spin my rotors too for my Hawk blue pads.

Suggestions? grease for hubs?
Impuls is offline   Reply With Quote
Old 12-04-2013, 12:15 AM   #152
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,093
Total Cats: 90
Default

Quote:
Originally Posted by Impuls View Post
Doing all my wheel bearings:
Front hubs are from Planetmiata.
Rear bearings are from parts store I know work for. Going to have them pressed in.

Also looking to replace/spin my rotors too for my Hawk blue pads.

Suggestions? grease for hubs?
Whatever rotors you can get cheapest, centric if you care about having a name brand. Turning them is a complete waste, unless its an auto-x car and you're turning brand new rotors down to the service limit to save weight.

AMS Dominator Grease is the only choice for the hubs.
Leafy is offline   Reply With Quote
Old 12-04-2013, 09:03 PM   #153
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Typical, the most expensive. Any dealers?

Also, what's the thread of the front hubs?
My computer here at O'Reilly's is showing two part numbers
615-145: m18x1.50.
oe part numbers: d06y33042, e9bz3b477a, na0133042a, na0133042b
05112: m20x1.50.
oe part numbers: same

They are also 30mm for the NB I suppose.
Impuls is offline   Reply With Quote
Old 12-04-2013, 09:12 PM   #154
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,093
Total Cats: 90
Default

Quote:
Originally Posted by Impuls View Post
Typical, the most expensive. Any dealers?
I got mine from Track Speed You got to contact them directly to order.
Leafy is offline   Reply With Quote
Old 12-05-2013, 10:33 AM   #155
Elite Member
iTrader: (8)
 
Join Date: Dec 2008
Location: Kingston, Ontario
Posts: 2,791
Total Cats: 71
Default

Quote:
Originally Posted by Leafy View Post
I got mine from Track Speed You got to contact them directly to order.
or just buy it from the source.
AMSOIL DOMINATOR Synthetic Racing Grease
shlammed is offline   Reply With Quote
Old 12-05-2013, 10:35 AM   #156
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,093
Total Cats: 90
Default

Quote:
Originally Posted by shlammed View Post
or just buy it from the source.
AMSOIL DOMINATOR Synthetic Racing Grease
I tried that. I made an order, got a confirmation email, card was never charged, never shipped, called them, said you had to be a dealer to buy direct.
Leafy is offline   Reply With Quote
Old 12-05-2013, 10:39 AM   #157
Elite Member
iTrader: (8)
 
Join Date: Dec 2008
Location: Kingston, Ontario
Posts: 2,791
Total Cats: 71
Default

Odd, I bought direct from amsoil before.

Thought I did buy the preferred membership as well. (good discount of 25%, paid for more than itself on my one purchase of engine oil, transmission fluid and diff fluid)

http://www.amsoil.com/shop/by-produc...-registration/
shlammed is offline   Reply With Quote
Old 12-05-2013, 10:54 AM   #158
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,465
Total Cats: 783
Default

Quote:
Originally Posted by Impuls View Post
I must be doing something wrong.
Turbo Miata Dyno - YouTube

At about 23 seconds you can see spark escaping my ignition wire.
Shitty MSM ignition & turbo? Not to mention running pressure well over what it's meant to run.
My AFR (yes shitty Prosport) says I'm in the 12-11.8 range. The dyno's AFR says I go pig rich at ~3900rpm

Ignore the file's title. haha


Dyno's sniffer is wrong. You wouldn't have a curve like that if your AFRs were like that.

MSM ignition shouldn't be holding you back yet. I made a bit more power than that on my MSM on stock ignition with no crazy issues, and my tach and speedo still work.


I'm behind on things... what turbo are you running now?
concealer404 is offline   Reply With Quote
Old 12-05-2013, 11:12 AM   #159
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by concealer404 View Post
Dyno's sniffer is wrong. You wouldn't have a curve like that if your AFRs were like that.

MSM ignition shouldn't be holding you back yet. I made a bit more power than that on my MSM on stock ignition with no crazy issues, and my tach and speedo still work.


I'm behind on things... what turbo are you running now?
Did you see the sparks escaping my wire in the video?
I figured mine couldn't be off, I leaned out fuel a bit in top end oh the heat soaked 190hp run and on the way home it felt like detonation was happening on WOT, like the car would jerk forward a bit AFRs would read ~12.8. so I riched it back up looked at plugs the next day and they look bad. rich on the outside lean white in the middle. looked at the top of my pistons and there was black and then a spot of metal that looked pitted.. after researching about it I got insta pissed.

I still have the stock MSM turbo. Stock exhaust size, gutted cat and glass pack.
Impuls is offline   Reply With Quote
Old 12-05-2013, 11:14 AM   #160
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,465
Total Cats: 783
Default

Quote:
Originally Posted by Impuls View Post
Did you see the sparks escaping my wire in the video?
I figured mine couldn't be off, I leaned out fuel a bit in top end oh the heat soaked 190hp run and on the way home it felt like detonation was happening on WOT, like the car would jerk forward a bit AFRs would read ~12.8. so I riched it back up looked at plugs the next day and they look bad. rich on the outside lean white in the middle. looked at the top of my pistons and there was black and then a spot of metal that looked pitted.. after researching about it I got insta pissed.

I still have the stock MSM turbo. Stock exhaust size, gutted cat and glass pack.
Couldn't see the sparks in the video.

Your ignition may be in need of servicing, but the reality is that a healthy MSM ignition is capable of supporting more power than the MSM turbo will put out.

Now, knowing that you're using a stock MSM turbo, your power numbers don't look bad.
concealer404 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Is my swirl pot design okay? FrankB Race Prep 10 10-02-2015 10:00 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Image resizer concealer404 Front Desk 3 09-29-2015 01:41 PM


Tags
because florida

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:18 AM.