Impuls build - Page 9 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 12-05-2013, 11:44 AM   #161
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by shlammed View Post
Odd, I bought direct from amsoil before.

Thought I did buy the preferred membership as well. (good discount of 25%, paid for more than itself on my one purchase of engine oil, transmission fluid and diff fluid)

AMSOIL Preferred Customer Registration
Turns out I still had an account with them from when I bought my Transmission oil, Ordered the sex grease haha

Quote:
Originally Posted by concealer404 View Post
Couldn't see the sparks in the video.

Your ignition may be in need of servicing, but the reality is that a healthy MSM ignition is capable of supporting more power than the MSM turbo will put out.

Now, knowing that you're using a stock MSM turbo, your power numbers don't look bad.
Hmm, Yeah I've been debating weather to do plugs and wires or trying to do LS truck coils but I'm not sure if MS2Pnp can do that

I was thinking maybe I'd be in the 220 range or even 230 being generous. Thought spark isn't fine tuned. I need to get a knock sensor and shielded audio cable to wire up my det can.
I also need a manifold, turbo, and exhaust :/ all pretty expensive things. But then I should be able to make ALLOFIT
Impuls is offline   Reply With Quote
Old 12-05-2013, 12:00 PM   #162
Elite Member
iTrader: (8)
 
Join Date: Dec 2008
Location: Kingston, Ontario
Posts: 2,791
Total Cats: 71
Default

if you see arc jump, just replace the wires.

plugs arent a bad thing to change on a regular basis...
shlammed is offline   Reply With Quote
Old 12-05-2013, 12:20 PM   #163
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,186
Total Cats: 2,582
Default

I would focus on figuring out your crazy electrical issue before anything else.
18psi is offline   Reply With Quote
Old 12-05-2013, 01:53 PM   #164
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by 18psi View Post
I would focus on figuring out your crazy electrical issue before anything else.
If I knew where to start it would be nice.
But I think sparking in the engine bay takes priority too.

I really do think you are right thought I'd like my gauge cluster to work as it did before I just have no idea what's wrong and I don't know where the grounding point is for it, to check if it's that. (Since the car did sit for nearly a year.)
Impuls is offline   Reply With Quote
Old 12-05-2013, 04:35 PM   #165
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Oh, for those that are interested.
The EFR7163 started shipping out last week.
Geoff has a single scroll vband EWG he offered me. I asked if any are twin yet. waiting on reply.
Though I want IWG, BUT Ehh not like I have the cash now anyways
Impuls is offline   Reply With Quote
Old 12-09-2013, 10:26 PM   #166
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Waiting on my Hawk blue pads still :/ were suppose to be here last week with the front hubs. Thanks planetmiata.
I got my new rotors, axle nuts, Amsoil DOMINATOR grease, and rear bearings.

Waiting on front spindle nuts too.


Anyone have a T3 turbo they don't want anymore?
Impuls is offline   Reply With Quote
Old 12-11-2013, 10:02 PM   #167
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Just waiting in front spindle nuts.
I had no idea they were actually blue!
Attached Thumbnails
Impuls build-c360_2013-12-11-19-39-19-952_zpsrsumeqad.jpg  
Impuls is offline   Reply With Quote
Old 12-14-2013, 10:29 PM   #168
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

The dyno operator hit launch control on the dyno today. Everyone about **** themselves, haha.

I thought it was funny.
Impuls is offline   Reply With Quote
Old 12-14-2013, 11:51 PM   #169
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

what happens when you dyno in 4th on a 6speed.




I'm not exactly sure how everything works with a dyno but shouldn't they need to know you're final drive and transmission gearing? Maybe someone can shed light on it for me besides me just talking to myself.

I go very rich after 5000, since I added fuel for safety I felt like something wasn't right while driving it. So they let me pull some fuel out (I only did a little) and this made the max run.

I guess I should just shift at 5250rpm I suppose.
Attached Thumbnails
Impuls build-c360_2013-12-14-22-41-37-503_zps1jz1fpev.jpg  
Impuls is offline   Reply With Quote
Old 12-15-2013, 08:24 PM   #170
Elite Member
iTrader: (8)
 
Join Date: Dec 2008
Location: Kingston, Ontario
Posts: 2,791
Total Cats: 71
Default

sounds good, but you have some gremlins to work out. lol
shlammed is offline   Reply With Quote
Old 12-15-2013, 10:17 PM   #171
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by shlammed View Post
sounds good, but you have some gremlins to work out. lol
Oh, do I ever.
I did some WOT pulls today with the rev limiter set to 7200, and I couldn't pass 6300 at 100% so I dropped throttle position and got close to 7000. I was running very rich. I think it was just a huge wall since my VE table with this small turbo looks stupid.

Spikes to 80 @ 4500-5000rpm then quickly tapers to 67's but still rich. Normal?


This was the dyno run that made the most, even after heat soaking.

184rwhp 196ft/lbs
Impuls is offline   Reply With Quote
Old 12-15-2013, 10:46 PM   #172
Elite Member
iTrader: (8)
 
Ryan_G's Avatar
 
Join Date: Jan 2012
Location: Tampa, Florida
Posts: 2,579
Total Cats: 155
Default

You have an MSM engine correct? I had a similar problem when I installed my MS2. Is the vtcs solenoid in the back of the intake manifold still plugged in? If it is you should unplug it.
Ryan_G is online now   Reply With Quote
Old 12-16-2013, 11:24 AM   #173
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by Ryan_G View Post
You have an MSM engine correct? I had a similar problem when I installed my MS2. Is the vtcs solenoid in the back of the intake manifold still plugged in? If it is you should unplug it.
Yeah, I remember that from when I first got the engine running. I don't believe it is but I'd have to check again. I thought with it connected you can't even go +5000rpm. I know I have the vac for the butterflies disconnected.

I'm thinking it may have something to do with the electronics ( gauge cluster ) going ape **** at anything above 5500rpm
Impuls is offline   Reply With Quote
Old 12-17-2013, 09:59 PM   #174
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

****, I forgot to check that plug.
Well I'm starting this week full time at my new job ( lame pay compared to my military paychecks ) so I haven't had the time to do a lot with the car, still waiting on the front spindle nuts. I think they are at the post office just don't have time to get them till Friday.

After work yesterday I I found that the axle I have in my trunk hit loose my positive battery terminal and spun it to where it made contact with the battery tie down causing an intermittent short that made the car jerk and all sorts of scary **** when it hit bumps it anything. This was very frustrating add I was in the middle of 5 o'clock downtown Tampa traffic abd I absolutely HATE traffic. So when I git on a road known as bayshore ( it follows Tampa bay to the south point being Macdill AFB) the car started jerking and hesitating very badly ( horrid rough roads) So what did my pissed off self do? I stabbed the gas heard a chunk of everything in my trunk and stared drifting around 2 bends with what seemed like good transitions but probably looked probably like the same as a Honda song a reverse-forward burnout. But now I have cord showing very badly on my tires so I ordered a new set to daily on.

tl;dr
Car act funny, jimmies rustled, sweet jdm drifto

I'm looking to get a cheap turbo to get me to 300 or more now(ultimate goal of breaking 400hp pump gas miata with EFR still there just need the job to pay for it). So I may enter the curio churbro leagues.
After taxes my fab guy gets a tig and REALLLY wants to do my hotside bits.
Hopefully he takes sexual advances at payment.

Last edited by Impuls; 12-17-2013 at 10:15 PM.
Impuls is offline   Reply With Quote
Old 12-18-2013, 12:31 PM   #175
Elite Member
iTrader: (8)
 
Join Date: Dec 2008
Location: Kingston, Ontario
Posts: 2,791
Total Cats: 71
Default

you should fix other issues before you bother changing the turbo
shlammed is offline   Reply With Quote
Old 12-18-2013, 04:04 PM   #176
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by shlammed View Post
you should fix other issues before you bother changing the turbo
This is true, I don't want anything to go wrong, When I get the time too troubleshoot the little things I will.

Anyone happen to have a 99 or 04msm knock sensor
or know if they work any good as an detcan? I'd like to not have to install and uninstall one every time it needs tuned, plus I need a new knock sensor.
Impuls is offline   Reply With Quote
Old 12-18-2013, 04:24 PM   #177
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,465
Total Cats: 782
Default

Quote:
Originally Posted by Impuls View Post
Yeah, I remember that from when I first got the engine running. I don't believe it is but I'd have to check again. I thought with it connected you can't even go +5000rpm. I know I have the vac for the butterflies disconnected.

I'm thinking it may have something to do with the electronics ( gauge cluster ) going ape **** at anything above 5500rpm

What's the reasoning here? Mine still runs it. We did have a problem when the polarity was reversed on the plug, though.
concealer404 is offline   Reply With Quote
Old 12-18-2013, 04:47 PM   #178
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,186
Total Cats: 2,582
Default

Quote:
Originally Posted by Impuls View Post
This is true, I don't want anything to go wrong, When I get the time too troubleshoot the little things I will.

Anyone happen to have a 99 or 04msm knock sensor
or know if they work any good as an detcan? I'd like to not have to install and uninstall one every time it needs tuned, plus I need a new knock sensor.
nope. they don't
18psi is offline   Reply With Quote
Old 12-18-2013, 05:43 PM   #179
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by concealer404 View Post
What's the reasoning here? Mine still runs it. We did have a problem when the polarity was reversed on the plug, though.
I couldn't tell you, I just know it doesn't let you rev.
Do you have a MSM engine with VTCS but running a 99-00 MS? That's what we're talking about I do believe.
So you're saying you just changed the polarity on = 1 off = 0 to on = 0 off = 1, like that? Or was it actually in the plug wiring

_____
Thanks vlad, I'd like to run ms with the knock sensor even though ms2's knock abilitys are nothing to write home about compared to ms3, but I also want a detcan I can install and use at any time.
Suggestions on the sensor to use for detcan? I have that harbor freight stethoscope, I was thinking it's some bosch with the right thread size.
Impuls is offline   Reply With Quote
Old 12-18-2013, 05:50 PM   #180
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,186
Total Cats: 2,582
Default

Jeff used to make those super awesome electronic det cans which he sold for 50 or 60
18psi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Is my swirl pot design okay? FrankB Race Prep 10 10-02-2015 10:00 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Image resizer concealer404 Front Desk 3 09-29-2015 01:41 PM


Tags
because florida

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:19 PM.