My awesome daily project 35mpg/150whp highway donut - Page 9 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-10-2012, 03:05 PM   #161
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I worked on enrichments a bit more for for some reason had to do some serious tuning in the upper kpa range. I will do more later since I'm still working from home on my real job.

Is there any reason I can't bolt on a 99 throttle body onto this 1994 plenum, change the settings, and have IAC again? I'm also going to run to homo-depot and get some PVC pipe to "delete MAF" later today.
hustler is offline   Reply With Quote
Old 04-10-2012, 03:14 PM   #162
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

The IAC and TPS will work fine with your ECU, no problems there. The TB will also bolt on, you will only need a longer lower right bolt IIRC.
Reverant is offline   Reply With Quote
Old 04-10-2012, 04:37 PM   #163
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Reverant View Post
The IAC and TPS will work fine with your ECU, no problems there. The TB will also bolt on, you will only need a longer lower right bolt IIRC.
Thanks. If you have the 9 IAC settings handy that will save me some time.

Thanks
hustler is offline   Reply With Quote
Old 04-10-2012, 04:45 PM   #164
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Use the same ones you have now, only lower the closed duty and minimum PID duty to 18%.
Reverant is offline   Reply With Quote
Old 04-10-2012, 05:36 PM   #165
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Well, I have a 99 T-body for the 1995 car but there are problems.
  • The 1994 TPS is a 4-wire, 1999 is a 3 wire
  • It appears the sensors will not swap over (please clarify if possible)
  • 99 IAC connector is different from the 1994
  • I have a 2001 harness but none of the sensor connectors seem to fit.
I guess I need to order a 99 engine harness unless anyone wants to sell me two 99-TPS pig-tails and one 99 IAC pigtail.
hustler is offline   Reply With Quote
Old 04-10-2012, 05:41 PM   #166
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Let's educate Hustler on how to rear a wire diagram and ultimately learn to think for himself...which is going to take work. I don't really know how to read a wire diagram.

I have a 1994 TPS:

I have a 1999 TPS:

How do I know which wires go where based upon wire color or the cool squiggly lines.

I'm guessing that the 1999 red/blk is the ground.
I'm guessing that the 1999 grn/blk is signal.
I'm guessing that the 1999 lt grn/red is power.

I don't know what the hell is going on with the 1994.

Thanks for the help, bros.
Attached Thumbnails
My awesome daily project 35mpg/150whp highway donut-1994-tps.png   My awesome daily project 35mpg/150whp highway donut-1999-tps.png  
hustler is offline   Reply With Quote
Old 04-10-2012, 05:43 PM   #167
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

The 99 and 01 use the same connectors for the TPS and IAC. So your 01 harness should have these.

The IAC will certainly not swap over from a 99 to a 94. I'm pretty sure about the TPS as well, but can't remember right now.
Reverant is offline   Reply With Quote
Old 04-10-2012, 05:45 PM   #168
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Reverant View Post
The 99 and 01 use the same connectors for the TPS and IAC. So your 01 harness should have these.

The IAC will certainly not swap over from a 99 to a 94. I'm pretty sure about the TPS as well, but can't remember right now.
Then maybe "The Parts Group" sold me something else because that harness has no connectors that fit on my 99 throttle body. There are some which are close, but they have grooves in the wrong places. I tried every connector, they don't fit.
hustler is offline   Reply With Quote
Old 04-10-2012, 05:46 PM   #169
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Quote:
Originally Posted by hustler View Post
I'm guessing that the 1999 blk/red is the ground.
I'm guessing that the 1999 grn/blk is signal.
I'm guessing that the 1999 lt grn/red is power.

I don't know what the hell is going on with the 1994.

Thanks for the help, bros.
Correct on the above.

One the 94:

blk/blue is the ground
red/blk is signal.
lt grn/white is power.
Reverant is offline   Reply With Quote
Old 04-10-2012, 05:50 PM   #170
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

Did your engine harness come with the fuel injector sub-harness? The IAC and TPS connectors will be at the end of that.
Bryce is offline   Reply With Quote
Old 04-10-2012, 05:52 PM   #171
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Bryce View Post
Did your engine harness come with the fuel injector sub-harness? The IAC and TPS connectors will be at the end of that.
Well, the injector harness is in a box for the golden-sequential swap in the green car, lol. Thanks, I bet I can find them now.

brb

Edit:
None of them fit the IAC nor the TPS.
hustler is offline   Reply With Quote
Old 04-10-2012, 06:12 PM   #172
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 9,642
Total Cats: 954
Default

I've got a spare 99/00 injector harness... I can check it when I get home against my 99/00 TB & TPS. I'll sell it to ya cheap!

Are you SURE your TB and TPS are 99/00?
EO2K is offline   Reply With Quote
Old 04-10-2012, 06:21 PM   #173
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Okay, I found the problem. I cut off the TPS and IAC pig-tails from my spare harness over the summer when I recieved it, then put them in a safe place so I would not find them the next time I went looking.
hustler is offline   Reply With Quote
Old 04-10-2012, 08:38 PM   #174
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I'm pulling my hair out over enrichments and I don't understand why they keep triggering when I hold full-throttle. Here is my stuff, specifically look at 20978-20980s in the log.
Attached Files
File Type: msl 2012-04-10_18.28.10.msl (161.2 KB, 41 views)
File Type: msq 18.msq (84.6 KB, 68 views)
hustler is offline   Reply With Quote
Old 04-10-2012, 08:42 PM   #175
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

I don't get it, this was easy as ---- on my turbo car and on all the NA cars I've tuned, for some reason my brain is not working this time or I'm most likely making a stupid mcsteak.
hustler is offline   Reply With Quote
Old 04-10-2012, 09:33 PM   #176
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Please also not that at the very beginning of the log I have an RPM dip just after TP goes +20%. I'm not sure how to get rid of that, but I'm thinking MAP enrichment like on my turbo car.

Here are some other things I guess I don't really understand.
MAP Enrich (my friend)
  • Mapdot threshold - the amound of MAP change required to initiate enrichment
  • Accel time - how long you want the full MAPdot enrichment to last
  • Taper time - how long to taper down to 0% enrichment after the Accel time period
  • end PW - I don't understand what this does if I'm already telling it when to taper to 0% in Taper time
TPS Enrich (Satanic enemy of decency, possibly communist)
  • TPSdot threshold - the minim % TP change to initiate enrichment
  • Why is there no taper? How do you guys run 100% TP and get a good enrichment tune?
  • In MLV, does TPSdot tell me how much PW its adding or something else?
hustler is offline   Reply With Quote
Old 04-10-2012, 10:30 PM   #177
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

annnnnnnnnnnnnnnnnnnd now its perfect, lol.

I was getting a weird oscillation at idle which I attached too. I'm guessing heat soak on the IAT since it was ~200*f IAT.

Can someone go to 252.896 in "oscillation" and tell me what's going in? The car is idling, then suddenly it starts squirting more fuel without enrichments triggering or any throttle application.

weird
Attached Thumbnails
My awesome daily project 35mpg/150whp highway donut-oscillation.jpg  
Attached Files
File Type: msl TpsMapEnrich.msl (623.4 KB, 58 views)
File Type: msl oscillation.msl (587.0 KB, 81 views)
File Type: msq 21.msq (84.6 KB, 73 views)

Last edited by hustler; 04-10-2012 at 10:40 PM.
hustler is offline   Reply With Quote
Old 04-11-2012, 07:33 PM   #178
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

The car is much much much better, I'm very happy with it today. I still have a question though. I've managed to dial-out the initial lean-ness on tip-in, but then its still going too fat for about .1s after tip in. You can see this at 3960.729 in this log. I'm not sure how to trim that all the way out when leaving from a stop.

I've never had enrichments and throttle response this good, I'd say its near ITB status when moving, I can't touch ITB free-revving.
Attached Thumbnails
My awesome daily project 35mpg/150whp highway donut-after-fat.jpg  
Attached Files
File Type: msl 2012-04-11_12.33.16.msl (1.50 MB, 78 views)
File Type: msq 23.msq (84.6 KB, 70 views)
hustler is offline   Reply With Quote
Old 04-11-2012, 08:01 PM   #179
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

Tps tpsdot > mapdot
Braineack is offline   Reply With Quote
Old 04-11-2012, 08:14 PM   #180
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Braineack View Post
Tps tpsdot > mapdot
I could not get TPSdot working on free rev. Any thoughts? This might be a scenario where there are two schools of thought that get the job done...I hope because I don't care to chase this down anymore.

How does my log look? Can it get better? My turbo car is not like this at all. I set it and forget it and the car drives great.
hustler is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 07:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:38 PM.